Bug 970178 - JobTracker and TaskTracker cannot run as root
JobTracker and TaskTracker cannot run as root
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-hadoop (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bradley Childs
Martin Bukatovic
:
Depends On:
Blocks: 1057253
  Show dependency treegraph
 
Reported: 2013-06-03 11:38 EDT by Steve Watt
Modified: 2014-03-03 11:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-03 11:31:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Watt 2013-06-03 11:38:43 EDT
Presently MapReduce will not work if the JobTracker is run under a user other than root due to the fact that the glusterfs plugin for Hadoop calls getfattr (via getFileBlockLocations) which requires superuser privileges.
Comment 2 Bradley Childs 2013-07-24 15:16:56 EDT
GA Workaround:

Job and Task trackers may run as any non root user, as long as its identical on all systems.  The UIDs must also match.  The  mapreduce job must also be submitted as the same user/UID.

In addition, each system must have a sudoers entry allowing sudo access to the getfattr command by the user that started the trackers and is submitting the job.

An example of the correct sudoers setup is creating a file /etc/sudoers.d/gluster, and add the line:

mapred ALL= NOPASSWD: /usr/bin/getfattr

where mapred is replaced by the user running the trackers + job.

Note You need to log in before you can comment on or make changes to this bug.