Bug 97018 - (SOUND AC97_CODEC)ac97_codec.c disables CMI9738 pcm volume control preventing unmute (no sound)
(SOUND AC97_CODEC)ac97_codec.c disables CMI9738 pcm volume control preventing...
Status: CLOSED DUPLICATE of bug 92043
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-08 19:29 EDT by Eric Brombaugh
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Brombaugh 2003-06-08 19:29:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Somewhere between kernels 2.4.20-8 and kernel-2.4.20-13.9,
drivers/sound/ac97_codec.c was patched with changes that added the CMI brand of
codecs. These codecs don't have full-on PCM volume controls and the patch
disables access to these vestigal registers. The trouble is that writing 0 to
the PCM volume control mutes them. Disabling access to these registers prevents
the subsequent initialization routines from unmuting the digital audio outputs.
Hence, no sound.

To fix this, remove the flag AC97_NO_PCM_VOLUME from the CMI entries in
ac97_codec_ids[].



Version-Release number of selected component (if applicable):
kernel-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1. Get a sound system with a CMI ac97 codec (I've got an ECS K7S5A)
2. Install RH9 with the latest kernel & boot
3. Try to play digital audio

    

Actual Results:  No audible digital audio

Expected Results:  Should hear something

Additional info:

Here's the ac97_codec output from the syslog from my machine booting under
different kernels.

2.4.20-8
May 26 15:36:05 amadeus kernel: ac97_codec: AC97  codec, id: CMI65 (Unknown)

2.4.20-13.9
May 26 15:39:41 amadeus kernel: ac97_codec: AC97  codec, id: CMI65 (CMedia)
May 26 15:39:41 amadeus kernel: AC97 codec does not have proper volume support.
Comment 1 Alan Cox 2003-06-09 07:49:32 EDT
That fix will work (the actual problem is that we ignore the non existant volume
control but it is valid as a mute still). I've already sent Arjan a fix for this
problem with a similar codec and SIS7012
Comment 2 Alan Cox 2003-06-10 13:37:54 EDT

*** This bug has been marked as a duplicate of 92043 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.