Bug 970194 - Tests hang when own-thread is set
Tests hang when own-thread is set
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: transport (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jeff Darcy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 12:15 EDT by Jeff Darcy
Modified: 2014-04-17 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:42:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log files of failures for './tests/bugs/bug-857330/normal.t' and './tests/bugs/bug-884455.t' (1.82 KB, application/x-gzip)
2013-06-05 12:34 EDT, John Smith
no flags Details

  None (edit)
Description Jeff Darcy 2013-06-03 12:15:01 EDT
Reported via list email:

cat /usr/lib*/glusterfs/$VERSION/filter/multi-thread.sh
#!/bin/sh
sed -i 's/.*type protocol.*/&\n    option transport.socket.own-thread on/' $1

and do './run-tests'. tests that otherwise succeed either fail or hang.
Comment 1 Anand Avati 2013-06-03 12:16:29 EDT
REVIEW: http://review.gluster.org/5137 (transport/socket: fix connect/disconnect races) posted (#1) for review on master by Jeff Darcy (jdarcy@redhat.com)
Comment 2 Anand Avati 2013-06-04 17:12:21 EDT
REVIEW: http://review.gluster.org/5137 (transport/socket: fix connect/disconnect races) posted (#2) for review on master by Jeff Darcy (jdarcy@redhat.com)
Comment 3 Anand Avati 2013-06-04 18:38:27 EDT
COMMIT: http://review.gluster.org/5137 committed in master by Anand Avati (avati@redhat.com) 
------
commit 5c1710ed60ccb151ccd7a2890b24bb99518d36da
Author: Jeff Darcy <jdarcy@redhat.com>
Date:   Tue Jun 4 15:20:45 2013 -0400

    transport/socket: fix connect/disconnect races
    
    We might receive a connect request while a disconnect is still in
    progress, requiring more states and (the return of) poller generation
    numbers to avoid redundant pollers.  We might also get either kind of
    request from within our own rpc_transport_notify upcall, so we have to
    avoid locking and use the PLEASE_DIE state instead.
    
    Change-Id: Icbaacf96c516b607a79ff62c90b74d42b241780f
    BUG: 970194
    Signed-off-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/5137
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 John Smith 2013-06-05 12:32:33 EDT
Thanks to the commit above, the 'prove' tests no longer hang for me when setting 'option transport.socket.own-thread on' in the .vol files.

However, now I am getting (intermittent) failues of these tests when own-thread is set :

./tests/bugs/bug-857330/normal.t
./tests/bugs/bug-884455.t

normal.t often completes without errors, and when it does fail it doesnt always fail at exactly the same sub-tests. I included the output of 2 different runs of the same test to show this. One run fails at TEST 13, and one run doesnt. I havent figured out a way to make the test fail 100% of the time. The test 'bug-884455.t' always fails for me when setting 'own-thread' on. Both tests succeed without error for the same git revision when 'own-thread' is not set in the .vol files.
Comment 5 John Smith 2013-06-05 12:34:09 EDT
Created attachment 757277 [details]
Log files of failures for './tests/bugs/bug-857330/normal.t' and './tests/bugs/bug-884455.t'
Comment 6 Niels de Vos 2014-04-17 07:42:42 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.