Bug 970197 - Sendmail::PMilter violates Milter protocol when max children reached
Sendmail::PMilter violates Milter protocol when max children reached
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Sendmail-PMilter (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 12:29 EDT by Jonathan Kamens
Modified: 2013-06-29 14:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: perl-Sendmail-PMilter-1.00-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 01:54:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to block instead of erroring on max children (2.90 KB, patch)
2013-06-03 12:29 EDT, Jonathan Kamens
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 85833 None None None Never

  None (edit)
Description Jonathan Kamens 2013-06-03 12:29:53 EDT
Created attachment 756407 [details]
patch to block instead of erroring on max children

When the maximum number of interpreters is set by a milter, and that maximum is reached, Sendmail::PMilter violates the Milter protocol by sending SMFIR_TEMPFAIL to the MTA rather than doing initial negotiation. An error code is not allowed there; negotiation is required.

I've posted a fix at https://rt.cpan.org/Ticket/Display.html?id=85833 and also attached it to this ticket. Please consider including it in the Fedora RPM for Sendmail::PMilter, since it's unlikely that it'll make it into the official Sendmail::PMilter release any time soon.
Comment 1 Fedora Update System 2013-06-13 09:18:40 EDT
perl-Sendmail-PMilter-1.00-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Sendmail-PMilter-1.00-8.fc19
Comment 2 Fedora Update System 2013-06-13 09:18:56 EDT
perl-Sendmail-PMilter-1.00-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Sendmail-PMilter-1.00-8.fc18
Comment 3 Fedora Update System 2013-06-13 14:09:22 EDT
Package perl-Sendmail-PMilter-1.00-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Sendmail-PMilter-1.00-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10797/perl-Sendmail-PMilter-1.00-8.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-23 01:54:02 EDT
perl-Sendmail-PMilter-1.00-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-06-29 14:20:26 EDT
perl-Sendmail-PMilter-1.00-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.