Bug 970199 - foreman-katello-engine using file based snippets instead of DB
foreman-katello-engine using file based snippets instead of DB
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Dmitri Dolguikh
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 12:36 EDT by Mike McCune
Modified: 2014-01-27 08:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:20:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-06-03 12:36:30 EDT
In the "Katello Kickstart Default" we reference:

<%= snippets "katello_registration" %>

which indicates to Foreman that it needs to load the snippet off disk:

https://github.com/witlessbird/foreman/blob/develop/lib/foreman/renderer.rb#L25

the issue is, snippets on disk are not editable by Foreman's webui and users are not able to view or edit the snippet referenced above.

foreman-katello-engine also adds an entry in the DB for:

"Subscription Manager Registration" 

which we should be using instead of the file based approach.
Comment 1 Dmitri Dolguikh 2013-06-06 09:38:07 EDT
fixed in ae5f3212cf4dd17cf4a89d8b0a792daea29d7011
Comment 3 Brad Buckingham 2013-06-06 17:58:54 EDT
Mass move to ON_QA
Comment 4 Corey Welton 2013-06-10 16:26:14 EDT
QE testing notes: so the basics of what we're testing here is that kickstart templates can be updated and deleted.  Prior to this fix, they could not be.
Comment 5 Corey Welton 2013-06-10 16:27:51 EDT
QE Verified.  I have been able to make modifications to templates and additional am able to delete templates.

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10005-1.noarch
* foreman-compute-1.1.10005-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10005-1.noarch
* foreman-postgresql-1.1.10005-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-11.el6sat.noarch
* katello-all-1.4.2-11.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-11.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-11.el6sat.noarch
* katello-glue-candlepin-1.4.2-11.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-11.el6sat.noarch
* katello-glue-pulp-1.4.2-11.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch
Comment 6 Mike McCune 2013-07-18 17:20:34 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.