Bug 970215 - Reclaim disk space workflow for installation destination is confusing and requires you to execute same task multiple times to be successful
Reclaim disk space workflow for installation destination is confusing and req...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 13:40 EDT by Larry O'Leary
Modified: 2014-10-16 21:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 14:07:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2013-06-03 13:40:33 EDT
Description of problem:
When performing an installation that will completely replace an existing installation, the reclaim space workflow seems broken and disconnected from the user. 

When the install hub is displayed, installation destination indicates "No disks selected." After attempting to resolve this by selecting the spoke and verifying that my disk is already selected and clicking done, I am informed that there is insufficient space on the selected disk. If I select "Reclaim space" I am then allowed to mark the existing partitions as deleted and when I click okay, I am taking back to the install hub where I can still see that no disk is selected. 

I once again must go back into the spoke to see that my disk is still selected and click done. Only to be presented with another dialog that tells me the disk hasn't been setup. I then tell it to auto-partition and click okay. Only to be taken back to the install hub with yet another error about installation destination not having a bootloader configured. 

If I am a user who doesn't understand this process, at this point I have given up as I am not sure what else I am supposed to do. These messages/errors should be handled in the installation destination spoke and not keep bringing the user back to the hub with no meaningful feedback or next step.

Version-Release number of selected component (if applicable):
19-Beta

How reproducible:
Always

Steps to Reproduce:
1. Launch installer on a machine that contains an existing disk with data.
2. Attempt to resolve the "No disk selected" error displayed on the installation destination spoke.

Actual results:
Error doesn't seem to go away until you enter the installation destination spoke three different times. The first two you need to complete the same action/workflow and the third time you need to click on the link at the bottom that says "Full disk summary and bootloader..."

Expected results:
Should be able to configure and select a disk within the installation destination spoke without having to invoke it multiple times.

Additional info:
Perhaps this is simply an issue with the reclaim space dialog throwing the user back to the install hub instead of back to the installation destination spoke. 

Additionally, the "no disk selected" message on the hub screen seems misleading considering the first thing the user sees when they enter the spoke is that the disk is checked/selected. Perhaps this message needs to be something more meaningful like "Insufficient space on currently selected disk." 

Finally, I think the default bootloader configuration should just be applied once the new partition is setup? Perhaps this isn't safe for multi-boot?
Comment 1 Chris Lumens 2014-02-26 15:47:50 EST
We've made an awful lot of changes to the partitioning work flow since F19.  If you could please give F20 (or even better - rawhide for F21) a try and see if that fixes up your problems, that would be helpful.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.