Bug 970251 - SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java from 'create' accesses on the directory .icedtea.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin...
Status: CLOSED DUPLICATE of bug 967298
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a7b603a25bd1a68b1b0e7b75b6b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 15:28 EDT by long
Modified: 2013-06-04 10:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 10:51:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description long 2013-06-03 15:28:30 EDT
Description of problem:
I erased ~/.icedtea to clear the cache.  Then I started firefox and tried to run a java applet.
SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java from 'create' accesses on the directory .icedtea.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that java should be allowed create access on the .icedtea directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                .icedtea [ dir ]
Source                        java
Source Path                   /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jr
                              e/bin/java
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           java-1.7.0-openjdk-1.7.0.19-2.3.9.4.fc17.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-169.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.13-100.fc17.x86_64 #1 SMP Mon
                              May 13 13:36:17 UTC 2013 x86_64 x86_64
Alert Count                   35
First Seen                    2013-06-03 14:26:57 CDT
Last Seen                     2013-06-03 14:26:58 CDT
Local ID                      553e3933-37e6-4019-a778-117286db61a7

Raw Audit Messages
type=AVC msg=audit(1370287618.625:234): avc:  denied  { create } for  pid=32356 comm="java" name=".icedtea" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir


type=SYSCALL msg=audit(1370287618.625:234): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=7ffa98000b70 a1=1ff a2=7ffb1df0f060 a3=14 items=0 ppid=32238 pid=32356 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=java exe=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19.x86_64/jre/bin/java subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: java,mozilla_plugin_t,user_home_dir_t,dir,create

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:dir create;

audit2allow -R

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:dir create;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.x86_64
type:           libreport

Potential duplicate: bug 967298
Comment 1 Miroslav Grepl 2013-06-04 10:51:57 EDT

*** This bug has been marked as a duplicate of bug 967298 ***

Note You need to log in before you can comment on or make changes to this bug.