Bug 970278 - oo-frontend-connect starts openshift-node-web-proxy with reload, even if the service is shut off
oo-frontend-connect starts openshift-node-web-proxy with reload, even if the ...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 17:18 EDT by chris alfonso
Modified: 2016-01-31 21:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 13:17:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris alfonso 2013-06-03 17:18:36 EDT
Description of problem:
When the --websocket argument is passed into oo-frontend-connect it will reload the openshift-node-web-proxy service. This is fine in most cases, but there are times where we need to turn that service off, and keep it off. Instead of calling of calling service openshift-node-web-proxy reload we should call condrestart so that if it's turned off, it won't restart the service.


Version-Release number of selected component (if applicable):


How reproducible:

Create an application for any cartridge that passes --websocket when the openshift-node-web-proxy is turned off. It'll start the service.


Steps to Reproduce:
1. service openshift-node-web-proxy stop
2. rhc app create app1 jbossews
3. service openshift-node-web-proxy status

Actual results:
openshift-node-web-proxy is on.

Expected results:
openshift-node-web-proxy is off.

Additional info:
The service script already has a condrestart option defined, we can use that.
Comment 1 Rob Millner 2013-06-03 17:20:24 EDT
We should add a "condreload" - restart is quite a bit more expensive than a reload on this service.
Comment 2 Rob Millner 2013-06-03 17:25:03 EDT
Actually, this is a little weirder.  As far as I can see the reload portion of the init script should not cause the daemon to start.  Will need to examine this further to see what is happening.
Comment 3 Rob Millner 2013-06-03 21:07:03 EDT
I can't reproduce this on the latest devenv with the following commands:

1. service openshift-node-web-proxy stop
2. rhc app create rmtest php-5.3
3. ps -ef |grep node                         # Shows nothing
4. service openshift-node-web-proxy status   # Shows web-proxy is stopped
5. service openshift-node-web-proxy reload   # Reports an error
6. service openshift-node-web-proxy status   # Still shows web-proxy is stopped.

Reading the code, that's exactly how it should behave.  Do you have an environment where this is happening I can have a look at?  Thanks!
Comment 4 chris alfonso 2013-06-04 10:34:13 EDT
I haven't been able to reproduce this either, v1 or v2. I'm going to follow up with the customer and dig a little deeper.
Comment 5 chris alfonso 2013-06-06 13:17:02 EDT
We were unable to reproduce this issue. Closing.

Note You need to log in before you can comment on or make changes to this bug.