Bug 97030 - wrong ifup order for xDSL connection at boot time
wrong ifup order for xDSL connection at boot time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-09 09:21 EDT by bastiaan
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 23:25:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bastiaan 2003-06-09 09:21:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The initialization order of network interfaces at boot time appears to be
determined by the alfabetical order of the device nicknames. This goes wrong if
you have an for example an xDSL device with a nickname < eth. In that case the
init script will try to start the xDSL device before the underlying ethernet
device. 
The ifcfg-<xDSL-device> has an 'ETH=' entry but it does not appear to be used by
the init scripts.
Unfortunately it's not possible to work around the issue by giving the xDSL
device another nick name: it must be equal to the Access Concentrator name
because PPP will lookup the AC name als 'server' value in /etc/ppp/chap-secrets
and redhat-config-network will put the nickname in that field. The 'ACNAME'
paramter in ifcfg-<xDSL-device> appears to be unused.
 

Version-Release number of selected component (if applicable):
initscripts-7.14-1

How reproducible:
Always

Steps to Reproduce:
1. create an xDSL device with nickname 'abc', with onboot=yes and ethernet
device eth0
2. reboot machine

    

Actual Results:  The xDSL device will fail to start up. On my machine,
subsequently the ethernet device will fail to start up as well, complaining
about not being able to load module 'tulip' (the ethernet device is a tulip
chipset based card)

Expected Results:  It should have started the ethernet device first and then the
xDSL device

Additional info:

This problem may be the sum of several bugs: ideally the nickname can be choosen
freely instead of being equal the the AC name.
Comment 1 Bill Nottingham 2003-09-03 23:25:24 EDT
Changed in 7.31-1; anything with TYPE=xDSL set will be brought up later.

Note You need to log in before you can comment on or make changes to this bug.