Bug 970307 - tracker-extract leaks file descriptors
tracker-extract leaks file descriptors
Status: CLOSED DUPLICATE of bug 1058547
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
abrt_hash:edbcd2cd505cbac5ab0fefc496c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 18:01 EDT by Vojta David
Modified: 2014-10-10 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-10 13:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (52.73 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: core_backtrace (2.48 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: dso_list (8.07 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: environ (1.01 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: maps (38.15 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: open_fds (41.15 KB, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details
File: var_log_messages (292 bytes, text/plain)
2013-06-03 18:01 EDT, Vojta David
no flags Details

  None (edit)
Description Vojta David 2013-06-03 18:01:08 EDT
Description of problem:
This is just keep happening randomly

Version-Release number of selected component:
tracker-0.16.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-extract
crash_function: g_wakeup_new
executable:     /usr/libexec/tracker-extract
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_wakeup_new at gwakeup.c:163
 #3 g_main_context_new at gmain.c:610
 #4 g_get_worker_context at gmain.c:5453
 #5 file_is_hidden at glocalfileinfo.c:1510
 #6 _g_local_file_info_get at glocalfileinfo.c:1791
 #7 g_local_file_enumerator_next_file at glocalfileenumerator.c:405
 #8 g_file_enumerator_next_file at gfileenumerator.c:228
 #9 find_local_cue_sheets at tracker-cue-sheet.c:331
 #10 tracker_cue_sheet_parse_uri at tracker-cue-sheet.c:371
 #11 tracker_extract_gstreamer at tracker-extract-gstreamer.c:1991
Comment 1 Vojta David 2013-06-03 18:01:12 EDT
Created attachment 756549 [details]
File: backtrace
Comment 2 Vojta David 2013-06-03 18:01:15 EDT
Created attachment 756550 [details]
File: cgroup
Comment 3 Vojta David 2013-06-03 18:01:18 EDT
Created attachment 756551 [details]
File: core_backtrace
Comment 4 Vojta David 2013-06-03 18:01:21 EDT
Created attachment 756552 [details]
File: dso_list
Comment 5 Vojta David 2013-06-03 18:01:24 EDT
Created attachment 756553 [details]
File: environ
Comment 6 Vojta David 2013-06-03 18:01:27 EDT
Created attachment 756554 [details]
File: limits
Comment 7 Vojta David 2013-06-03 18:01:30 EDT
Created attachment 756555 [details]
File: maps
Comment 8 Vojta David 2013-06-03 18:01:34 EDT
Created attachment 756556 [details]
File: open_fds
Comment 9 Vojta David 2013-06-03 18:01:37 EDT
Created attachment 756557 [details]
File: proc_pid_status
Comment 10 Vojta David 2013-06-03 18:01:41 EDT
Created attachment 756558 [details]
File: var_log_messages
Comment 11 gordon 2014-01-01 06:12:23 EST
just installed fedora 19
booted up this morning and opened the terminal (to do 'su -c 'yum update')
got loads of bug reports
now running update

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-extract
crash_function: g_wakeup_new
executable:     /usr/libexec/tracker-extract
kernel:         3.9.5-301.fc19.i686
package:        tracker-0.16.1-3.fc19
reason:         Process /usr/libexec/tracker-extract was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
Comment 12 Fedora Admin XMLRPC Client 2014-07-26 13:11:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Admin XMLRPC Client 2014-07-27 02:33:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 14 Debarshi Ray 2014-10-10 13:20:16 EDT

*** This bug has been marked as a duplicate of bug 1058547 ***

Note You need to log in before you can comment on or make changes to this bug.