Bug 97036 - kword: formulas do not display right
Summary: kword: formulas do not display right
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-09 14:47 UTC by Gerald Teschl
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 10:25:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2003-06-09 14:47:00 UTC
Description of problem:
Formulas do not display right in kword due to a font problem.



Version-Release number of selected component (if applicable):
koffice-1.2.1-7

How reproducible:
100%

Steps to Reproduce:
1. Open a new kword document
2. Insert a formula
3. Insert a sum
    
Actual results:
Instaed of a sum sign you will get a lower case a with a circle
on top of it.

Expected results:
A sum sign

Additional info:
LANG=en_US.UTF-8 (also tried LANG=en_US, but it made no difference)

Comment 1 Gerald Teschl 2003-07-21 17:57:19 UTC
Still present in koffice-1.2.1-11

Comment 2 Gerald Teschl 2003-10-01 21:54:08 UTC
Still present in 1.2.1-14

Comment 3 Gerald Teschl 2003-11-14 21:20:12 UTC
Still present in koffice-1.2.1-15

Comment 4 Gerald Teschl 2004-05-12 08:59:32 UTC
Still present in koffice-1.3-6

Comment 5 Ngo Than 2004-05-12 14:07:52 UTC
it seems it's a bug in qt, which just ignores Symbol font

Comment 6 Ngo Than 2004-05-21 14:39:09 UTC
it's now fixed in qt-3.3.2-4. It should be in rawhide now

Comment 7 Gerald Teschl 2004-06-03 09:32:19 UTC
I have qt-3.3.2-5 but it still does not work?

Comment 8 Ngo Than 2004-10-28 10:25:53 UTC
it looks like the kformula does not work with the symbol font, but
it works fine with tetex fonts and esstix fonts,
ftp://ftp.elsevier.nl/pub/styles/esstix/esstix.zip. For workaround,
please install the esstix fonts.

there's already a bug report in KDE bugzilla.


Note You need to log in before you can comment on or make changes to this bug.