Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 970470 - Return "503 Error" when accessing mongolab-openshift-quickstart
Summary: Return "503 Error" when accessing mongolab-openshift-quickstart
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Templates
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Fotios Lindiakos
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-04 05:58 UTC by Wei Sun
Modified: 2015-05-15 02:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-22 15:15:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
log in STG (9.49 KB, text/x-log)
2013-06-05 02:49 UTC, Wei Sun
no flags Details
log in devenv (3.01 KB, text/x-log)
2013-06-05 02:50 UTC, Wei Sun
no flags Details

Description Wei Sun 2013-06-04 05:58:54 UTC
Description of problem:
Create mongolab-openshift-quickstart as follow README.md,and try to access the app's url,but it returns 503 error.

Version-Release number of selected component (if applicable):
STG(devenv-stage_357)

https://github.com/openshift/mongolab-openshift-quickstart

How reproducible:
Always

Steps to Reproduce:
1.Create mongolab-openshift-quickstart as follow README.md
2.Access the app's url
3.

Actual results:
It returns 503 error

Expected results:
Can access app's url successfully

Additional info:

Comment 1 Dan McPherson 2013-06-04 20:24:08 UTC
I tried to recreate this and the app still seemed to be functional.  Did you make any app changes besides what's stated in the README.md?

Did you have errors on git push?

Were there errors in the nodejs log?

Was you app in a running state when you were getting the 503?

Comment 2 Wei Sun 2013-06-05 02:49:42 UTC
Created attachment 757034 [details]
log in STG

Comment 3 Wei Sun 2013-06-05 02:50:26 UTC
Created attachment 757035 [details]
log in devenv

Comment 4 Wei Sun 2013-06-05 02:51:24 UTC
I tried to recreate this in STG(devenv-stage_357),still returns 503,but my app's status was started.
I did not make any app changes,only followed the README.md.
There were some errors in node.log,please refer to #attachment 1 [details]

And I also tried to recreate this in the latest devenv(devenv_3319),but app was ok.I could access the app's url successfully.But in node.log,there were some errors,please refer to #attachment 2 [details]

Comment 5 Lokesh Mandvekar 2013-06-07 15:56:33 UTC
I'm getting the same error as #attachment 1 [details] on Online.

Comment 6 Fotios Lindiakos 2013-06-18 13:32:07 UTC
I get this problem using the upstream https://github.com/mongolab/mongolab-openshift-quickstart because they haven't accepted our V2 compatability pull request yet.

This works just fine with our fork which does have the V2 changes. I will attempt to contact somebody at MongoLabs to try to get them to accept the PR.

Comment 7 Fotios Lindiakos 2013-06-24 14:14:29 UTC
This pull request was merged over the weekend, please retest.

Comment 8 Fotios Lindiakos 2013-06-24 17:28:23 UTC
FYI, this application will return a 503 unless it is configured with an API key. We are working with the partner to fix this so it will return a placeholder page if not properly configured.

Comment 9 Wei Sun 2013-06-25 03:28:08 UTC
Test this quickstart in devenv_3409.It works now.


Note You need to log in before you can comment on or make changes to this bug.