Bug 970473 - visit page duplicates.cgi and 502 Proxy Error happened
visit page duplicates.cgi and 502 Proxy Error happened
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Performance (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 02:02 EDT by wangjing
Modified: 2014-07-21 00:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-21 00:31:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for comment0 (47.85 KB, image/png)
2013-06-04 02:02 EDT, wangjing
no flags Details

  None (edit)
Description wangjing 2013-06-04 02:02:16 EDT
Created attachment 756625 [details]
screenshot for comment0

Description of problem:
visit page duplicates.cgi and 502 Proxy Error happened

Version-Release number of selected component (if applicable):
prod env version 4.4-3.3

How reproducible:
always

Steps to Reproduce:
1. click 'Most frequently reported bugs' in 'Most Common Actions' section on homepage. 
2. check the result.

Actual results:
502 Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /duplicates.cgi.

Reason: Error reading from remote server

Expected results:
duplicates.cgi page would be shown up.

Additional info:
screenshot attched.
Comment 1 wangjing 2013-06-04 03:18:17 EDT
more infos for this bug:
tried for 4 times on prod env, always happened this problem as comment0.
tried for 3 times on QE test env, 2 times correct but one time met errors like:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, sysadmin-engops@redhat.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Comment 4 Jason McDonald 2013-10-15 03:16:15 EDT
This behaviour still happens on the production server, taking around two minutes to show the 502 error page, but does not cause a long query timeout notification to be sent to the admin list.
Comment 6 Jason McDonald 2014-07-21 00:31:55 EDT
This issue appears to have been fixed by the recent migration to the new webservers and mod_perl.

Now, visiting https://bugzilla.redhat.com/duplicates.cgi takes about 15 seconds the first time and about 5 seconds on subsequent visits (the speedup being due to the caching performed by both the database and mod_perl).

This suggests that the problem was on the webserver side, which would explain the previously noted lack of a long query timeout notification from the database (and the apparent lack of related entries in the slow query logs).

Tested using Fedora 20 and Firefox 30.0.

Note You need to log in before you can comment on or make changes to this bug.