Bug 970502 - chapter, section, and process should not require a nested topic
chapter, section, and process should not require a nested topic
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 03:56 EDT by Eva Kopalova
Modified: 2016-06-17 17:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 18:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eva Kopalova 2013-06-04 03:56:17 EDT
Description of problem:
If a section/chapter/process is a topic itself and does not contain any other topic, the content spec is invalid.

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1.create a content spec map with the following:
Chapter: Process Elements
  Defining Process Elements properties [13962]
  Section: Input editors [16046]
  Section: Forms [16722]
    Defining Process form [16723]
2.try to push the map

Actual results:

CSProcessor client version: 0.32.3
Loading configuration from /home/eko/.config/csprocessor.ini
Connecting to PressGang server: http://skynet.usersys.redhat.com:8080/TopicIndex/

Starting to parse...
Starting first validation pass...
ERROR: Line 53: Invalid Section! No topics or levels in this Section.
       -> Section: Input editors [16046]


Expected results:
validation passes
Comment 1 Lee Newson 2013-06-04 18:36:32 EDT
If a Section only has "Introduction Text" then it in itself is just an ordinary topic, so you should just do the following:

Chapter: Process Elements
  Defining Process Elements properties [13962]
  Input editors [16046]
  Section: Forms [16722]
    Defining Process form [16723]

As for Chapter it will allow the format you specified, and the same goes for a Process.
Comment 2 Eva Kopalova 2013-06-05 04:46:18 EDT
Chapter: Process Elements
  Defining Process Elements properties [13962]
  Section: Input editors [16046]
  Section: Forms [16722]
    Defining Process form [16723]

is not the same like:

Chapter: Process Elements
  Defining Process Elements properties [13962]
  Input editors [16046]
  Section: Forms [16722]
    Defining Process form [16723]

The Input editor topic should be nested under 
Defining Process Elements properties

But it is not the same section as Forms which is also under
 Defining Process Elements properties [13962]

There is no difference in rendering, but there is a difference in the semantics of the content spec.
The other option is to drop the Section: thing all together and let the indenting decide... otherwise this is misleading.
Comment 3 Lee Newson 2013-06-05 18:49:34 EDT
It seems you are getting confused here about the syntax, anyways this is not a bug as a Section without children elements is just a topic. So, if "Input Editors" should be a child (nested element) of "Defining Process Elements properties" and so should "Forms", then the syntax should be:

Chapter: Process Elements
  Section: Defining Process Elements properties [13962]
    Input editors [16046]
    Section: Forms [16722]
      Defining Process form [16723]

If that still isn't right then feel free to email me with a better explanation.

As for dropping the section thing, as I've mentioned to you before that is not possible.

Note You need to log in before you can comment on or make changes to this bug.