Bug 970519 - [RFE] Add support for suppressing group members
[RFE] Add support for suppressing group members
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
: FutureFeature
Depends On: 832104
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 04:45 EDT by Kaushik Banerjee
Modified: 2013-11-21 17:19 EST (History)
17 users (show)

See Also:
Fixed In Version: sssd-1.9.2-102.el6
Doc Type: Enhancement
Doc Text:
Feature: A new option to avoid downloading group members was added. Reason: In many deployments, the administrator cares only about retrieving group memberships for the user, not the other way around. Moreover, if group members are not downloaded and stored to cache, SSSD gets a significant performance boost. Result (if any): The administrator may now to disable downloading group members, resulting in large performance gains.
Story Points: ---
Clone Of: 832104
Environment:
Last Closed: 2013-11-21 17:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Jakub Hrozek 2013-06-20 07:19:28 EDT
Fixed upstream in both master and sssd-1-9
Comment 9 Nikolai Kondrashov 2013-09-25 06:12:39 EDT
Verified as fixed by running ignore_group_members suite with sssd 1.9.2-127.el6 on RHEL6.5.
Comment 10 Eugene Keck 2013-10-11 09:53:57 EDT
GSS Approved for Hot Fix

---------------------------------------------

* Customer impact (or Business case)
Initial login from users take a long time. Up to 8 minutes if they have a large number of group memberships. This slow downs initial logins and sudo. This is not really acceptable to the customer because they have to manage about 350 Linux hosts. Migration from winbind to sssd was a recommendation from RedHat, because sssd would be faster than winbind.

As they plan to release this in about 3 weeks. They do not want to wait till Red Hat 6.5 is released.
Comment 16 errata-xmlrpc 2013-11-21 17:19:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1680.html

Note You need to log in before you can comment on or make changes to this bug.