Bug 970520 - [RFE] prevent VMS from pausing when using allocated disks
[RFE] prevent VMS from pausing when using allocated disks
Status: CLOSED DUPLICATE of bug 1024428
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.1.2
All All
medium Severity high
: ---
: 3.5.0
Assigned To: Tal Nisan
Haim
storage
: FutureFeature, Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 04:47 EDT by Karim Boumedhel
Modified: 2015-02-16 14:37 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 10:05:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)
hook to set errorpolicy to report for all disks or selected ones (988 bytes, text/x-python)
2013-06-04 04:47 EDT, Karim Boumedhel
no flags Details

  None (edit)
Description Karim Boumedhel 2013-06-04 04:47:11 EDT
Created attachment 756660 [details]
hook to set errorpolicy to report for all disks or selected ones

Description of problem:
when the storage domain of one of the disks of a VM experiences failure,
the VM will go on pause .
while this might be helpful when using thin provisioning, behaviour should be configurable when using preallocated disks, so the policy changes to report to OS and have the VM handle the lack of storage ( for instance using mdadm or ha-lvm with disks from other storage domains )




Version-Release number of selected component (if applicable):
3.1.X

How reproducible:
have a storage domain fail


Steps to Reproduce:
1.have a storage domain fail
2.
3.

Actual results:
all vm with disks in this SD will go pausing


Expected results:
give the ability to report the I/O error 

Additional info:
find attached a proposed before_vm_start hook that will change the errorpolicy to report upon launching vm 



having this makes it possible to 
-set red hat clusters using virtual machines
-use a Business Disaster Recovery solution using raid software (like mdadm ) for VMS , as long as they are presented with disks from 2 differents storage domains (one from both site)
Comment 1 Itamar Heim 2013-06-06 08:37:52 EDT
what's the implication - will the disk move to error, or blocks trying to be written to will be marked 'bad blocks', which will stay that way when the storage comes back?
Comment 2 Karim Boumedhel 2013-06-06 09:56:45 EDT
hello itamar,
when we let OS handle the I/O error, either using mdadm or lvm, disk from the failed storage domain will be marked as such and OS will handle properly the situation with no impact at lvm level.
when disk gets back, standard OS procedures will be applied to sync back data.
Comment 3 Itamar Heim 2013-06-09 05:18:04 EDT
Ayal - do you see a disk level field for this, a supported custom level property at disk level (now that we have device level custom properties), or just the external hook approach?
Comment 5 Ayal Baron 2013-09-04 17:28:31 EDT
(In reply to Itamar Heim from comment #3)
> Ayal - do you see a disk level field for this, a supported custom level
> property at disk level (now that we have device level custom properties), or
> just the external hook approach?

Should be advanced per VM disk level field, similar to cache mode
Comment 9 Ayal Baron 2013-12-15 10:05:45 EST

*** This bug has been marked as a duplicate of bug 1024428 ***

Note You need to log in before you can comment on or make changes to this bug.