Bug 970537 - needs groff-base to work properly, but does NOT require
needs groff-base to work properly, but does NOT require
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-ronn (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ricky Elrod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 05:36 EDT by Björn "besser82" Esser
Modified: 2013-06-11 05:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: rubygem-ronn-0.7.3-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 22:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn "besser82" Esser 2013-06-04 05:36:19 EDT
Description of problem:
using /bin/ronn $_file to build a manpage from mark-down without having groff-base installed will fail.


Version-Release number of selected component:
0.7.3 (rubygem-ronn-0.7.3-3.fc19.noarch)


How reproducible:
always when groff-base is not installed or pulled-in through otherwise needed dependency, e.g. during mock or koji-build


Steps to Reproduce:
1. create spec-file with `BuildRequires: rubygem-ronn`
   don't have `BuildRequires: groff-base`
   convert mark-down to manpage invoking /bin/ronn ${_file} during %build
2. build package with mock or koji-build
3. have a look inside {build,root}.log

Actual results:
groff-base will not get installed as required and build.log shows like:

     roff: ./${_file}.1
  sh: groff: command not found
     html: ./${_file}.1.html                                    +man


Expected results:
/bin/ronn should create manpage properly.


Proposed solution:
groff-base should get installed through dependency, since it is needed during `/bin/ronn`-invocation. rubygem-ronn should have Requires: groff-base


Additional info (see {build,root}.log):
without groff-base: https://koji.fedoraproject.org/koji/taskinfo?taskID=5463867
with groff-base:    https://koji.fedoraproject.org/koji/taskinfo?taskID=5463901
Comment 1 Fedora Update System 2013-06-04 13:21:42 EDT
rubygem-ronn-0.7.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-ronn-0.7.3-4.fc19
Comment 2 Fedora Update System 2013-06-04 13:29:02 EDT
rubygem-ronn-0.7.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-ronn-0.7.3-4.fc18
Comment 3 Björn "besser82" Esser 2013-06-04 13:31:32 EDT
Thanks for your quick bugfix!
Comment 4 Ricky Elrod 2013-06-04 14:05:52 EDT
No problem, thanks for reporting it!
Comment 5 Fedora Update System 2013-06-04 22:28:56 EDT
Package rubygem-ronn-0.7.3-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-ronn-0.7.3-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9989/rubygem-ronn-0.7.3-4.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-06-05 22:21:27 EDT
rubygem-ronn-0.7.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-06-11 05:13:32 EDT
rubygem-ronn-0.7.3-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.