Bug 970544 - hot-plugging serial device with no chardev option exits qemu
Summary: hot-plugging serial device with no chardev option exits qemu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-04 09:52 UTC by Paolo Bonzini
Modified: 2015-12-04 16:13 UTC (History)
8 users (show)

Fixed In Version: qemu 2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:13:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Paolo Bonzini 2013-06-04 09:52:53 UTC
Hot-plugging a PCI serial device like this:

(qemu) device_add id=ff,driver=pci-serial

will print "Can't create serial device, empty char device" and exit.  Not sure how easy to fix it is, though some of the infrastructure is there (realize methods can return an Error object, but PCI still uses the old init method).

Comment 4 Gerd Hoffmann 2015-04-30 15:47:50 UTC
pci init switched to realize in 2.3, so we can look into fixing that one now.

Comment 5 Gerd Hoffmann 2015-05-06 10:58:05 UTC
Looked at the code, seems the conversion to realize already fixed that one.

Comment 6 Qunfang Zhang 2015-06-23 07:11:52 UTC
Hi, Gerd

I tested this bug on old version qemu-kvm-rhev-2.1.2-23.el7_1.3.x86_64, got the following prompts:

(qemu)  device_add id=ff,driver=pci-serial
Can't create serial device, empty char device
Device initialization failed.
Device 'pci-serial' could not be initialized


And also tested on latest qemu-kvm-rhev-2.3.0-4.el7:

(qemu) device_add id=ff,driver=pci-serial
Can't create serial device, empty char device
Device 'pci-serial' could not be initialized

Gerd, is this the expected behaviour after fix? The qemu does not exit any more. But seems I did not reproduce it on old qemu-2.1.

Comment 7 Gerd Hoffmann 2015-06-23 07:25:51 UTC
Original report was for qemu-kvm, so you need 1.5.3 to reproduce I think.

Comment 8 Qunfang Zhang 2015-06-23 08:46:59 UTC
Yes, tested on the qemu-kvm-1.5.3-86.el7_1.1.x86_64, hot-plug a serial device with no chardev option, the qemu exits. 

(qemu) device_add id=ff,driver=pci-serial
Can't create serial device, empty char device
/etc/qemu-ifdown: could not launch network script
[root@localhost home]# 

So, according to comment 6 and comment 7, this bug is fixed in the latest qemu-kvm version.

Comment 12 errata-xmlrpc 2015-12-04 16:13:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.