Bug 970545 - ovirt-engine-reports-setup doesn't support option --help
ovirt-engine-reports-setup doesn't support option --help
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.1.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Yaniv Lavi (Dary)
Barak Dagan
infra
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-06-04 05:53 EDT by Petr Spacek
Modified: 2016-02-10 14:03 EST (History)
7 users (show)

See Also:
Fixed In Version: rhevm-reports-3.3.0-4.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:54:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Spacek 2013-06-04 05:53:25 EDT
Description of problem:
ovirt-engine-reports-setup doesn't support option --help

Version-Release number of selected component (if applicable):
rhevm-reports-3.1.0-20.el6ev.noarch

How reproducible:
100 %

Steps to Reproduce:
$ ovirt-engine-reports-setup --help
Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service? (yes|no):

Actual results:
Installation is started immediately.

Expected results:
A help message is printed, including some hint about uninstallation etc.
Comment 2 David Botzer 2013-07-10 04:34:15 EDT
3.3/is4
rhevm-dwh-3.3.0-4.el6ev.noarch.rpm  
rhevm-reports-3.3.0-5.el6ev.noarch.rpm 
jasperreports-server-pro-5.2.0-1.el6ev.noarch

I get the below:
------------------------------------
(* ovirt-engine-reports-setup)

>>rhevm-reports-setup --help
usage: rhevm-reports-setup [-h]

Installs or upgrades your oVirt Engine Reports

optional arguments:
  -h, --help  show this help message and exit
-------------------------------------
1. No hint about uninstallation
2. Are there any other option for the installation that we need --help ?
   e.x answer file, ports config
Comment 3 Yaniv Lavi (Dary) 2013-07-10 05:11:22 EDT
(In reply to David Botzer from comment #2)
> 3.3/is4
> rhevm-dwh-3.3.0-4.el6ev.noarch.rpm  
> rhevm-reports-3.3.0-5.el6ev.noarch.rpm 
> jasperreports-server-pro-5.2.0-1.el6ev.noarch
> 
> I get the below:
> ------------------------------------
> (* ovirt-engine-reports-setup)
> 
> >>rhevm-reports-setup --help
> usage: rhevm-reports-setup [-h]
> 
> Installs or upgrades your oVirt Engine Reports
> 
> optional arguments:
>   -h, --help  show this help message and exit
> -------------------------------------
> 1. No hint about uninstallation

Not in the scope of the help. Also it's self explanatory 'yum remove'. 

> 2. Are there any other option for the installation that we need --help ?

Not to date.

>    e.x answer file, ports config
Comment 4 David Botzer 2013-07-10 05:20:53 EDT
Fixed, 3.3/is4
rhevm-dwh-3.3.0-4.el6ev.noarch.rpm  
rhevm-reports-3.3.0-5.el6ev.noarch.rpm 
jasperreports-server-pro-5.2.0-1.el6ev.noarch
Comment 5 Charlie 2013-11-27 19:49:57 EST
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 09:54:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0035.html

Note You need to log in before you can comment on or make changes to this bug.