Bug 970555 - assertion failure on hot-unplug of ivshmem
assertion failure on hot-unplug of ivshmem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 06:28 EDT by Paolo Bonzini
Modified: 2013-08-31 15:32 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 15:32:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2013-06-04 06:28:04 EDT
/usr/libexec/qemu-kvm /vm/test-base.qcow2 -vnc :1 -m 2048 \
   -monitor stdio \
   -chardev backend=socket,path=`pwd`/foo.sock,id=foo,server,nowait \
   -device id=ff,chardev=foo,driver=ivshmem
QEMU 1.5.0 monitor - type 'help' for more information
(qemu) device_del ff
memory_region_del_subregion: Assertion `subregion->parent == mr' failed.

This is because create_shared_memory_BAR has not been called yet.
Comment 4 Cole Robinson 2013-08-31 15:32:10 EDT
This doesn't seem to crash with qemu 1.6

Note You need to log in before you can comment on or make changes to this bug.