Bug 970558 - creation of a bootable volume from an image does not honor size parameter
creation of a bootable volume from an image does not honor size parameter
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity urgent
: rc
: 3.0
Assigned To: Eric Harney
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 06:58 EDT by Giulio Fidente
Modified: 2016-04-26 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, volumes created from Glance images were not being re-sized according to the passed parameters, when using NFS or GlusterFS backends, even though Cinder's DB reported the correct size. This has been fixed so that the backing file gets re-sized correctly as shown in Cinder DB.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 13:16:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 30298 None None None Never

  None (edit)
Description Giulio Fidente 2013-06-04 06:58:29 EDT
Description of problem:
volumes created from glance images are saved on database with using the size passed as argument but the actual image file does not get resized accordingly


Version-Release number of selected component (if applicable):
openstack-cinder-2013.1.1-3.el6ost


Steps to Reproduce:
1. create an image in glace
2. crate a volume from such an image and pass "1" as volume size


Actual results:
the volume will be reported as of 1Gb but the actual file in the filesystem will match instead the virtual size reported by qemu-img for the glance image


Expected results:
the volume is resized to the value passes as arg if that is bigger than the actual image size (virtual size)


Additional info:
upstream bug: https://bugs.launchpad.net/cinder/+bug/1183459
Eric suggests this should fix it: https://review.openstack.org/#/c/30298
Comment 2 Giulio Fidente 2013-06-13 07:26:50 EDT
verified using openstack-cinder-2013.1.2-3.el6ost.noarch
Comment 5 errata-xmlrpc 2013-06-27 13:16:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.