Bug 970579 - Different left menu between page that ends with .do and .pxt in category "Channels"
Different left menu between page that ends with .do and .pxt in category "Cha...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Martin Korbel
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2013-06-04 08:02 EDT by Pavel Studeník
Modified: 2013-10-01 17:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-web-2.0.3-14-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:53:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of left-menu (145.52 KB, image/png)
2013-08-28 08:06 EDT, Pavel Studeník
no flags Details
left menu (121.07 KB, image/png)
2013-09-25 06:13 EDT, Martin Korbel
no flags Details

  None (edit)
Description Pavel Studeník 2013-06-04 08:02:05 EDT
Description of problem:
Pages contain different left menu (without some items) in "Channels".  This problem have only page that ends with .pxt (perl).

following links:
/network/systems/system_list/in_channel_family.pxt?cfam_id=1173
/network/systems/system_list/regular_in_channel_family.pxt?cfam_id=1173
/network/software/channels/manage/managers.pxt?cid=107

Version-Release number of selected component (if applicable):
spacewalk-html-1.9.22-9.el6sat.noarch


How reproducible:
always - link to new features in 5.6 

Steps to Reproduce:
1. Channels -> Software Channel Management -> [channel] -> Managers
2. Subscription Management -> Software Channel Entitlements -> [choose channel - Systems Subscribed/Regular Consumed ]

Actual results:
Left menu doesn't contain items: Manage Repositories, Distribution Channel Mapping

Expected results:
Left menu contain all items
Comment 2 Tomáš Kašpárek 2013-06-13 05:43:49 EDT
commited fix into spacewalk master: 47d17447c1c1dee9a3626b981e00e4288c118178

I've also added links to Software Crashes and Physical Systems on Systems tab
Comment 5 Pavel Studeník 2013-08-28 08:06:50 EDT
Created attachment 791363 [details]
screenshot of left-menu
Comment 7 Pavel Studeník 2013-09-02 05:47:42 EDT
I created new bug bz1003530 for comment 4.  

The left-menu is displayed correctly on Channels pages (all items of menu is shown).

Verified on spacewalk-java-2.0.2-25.el6sat.noarch
Comment 11 Tomáš Kašpárek 2013-09-03 02:58:26 EDT
missing links fixed in spacewalk.git: 35a56d1a0e5ec2764262f73193398d3d4b7bfae7
Comment 14 Martin Korbel 2013-09-25 06:13:13 EDT
Created attachment 802719 [details]
left menu

VERIFIED on spacewalk-web-2.0.3-16.el6sat, but bz1003530 is here still.
REPRODUCED on spacewalk-html-1.2.7-22.el6sat (Sat5.4.1)

- Channels -> Software Channel Management -> [channel] -> Managers - this page is now java page.
- Subscription Management -> Software Channel Entitlements -> [choose channel - Systems Subscribed/Regular Consumed ] - fixed
- old logo on top of page - fixed
- wrong text in footer "Red Hat Network release" and year 2012 -fixed
- lost name of organization in top gray bar - still missing
Comment 15 Clifford Perry 2013-10-01 17:53:48 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.