Bug 970587 - Backport the JBCOMMON-25 / JBPAPP-3336 into EAP 5.2.0
Summary: Backport the JBCOMMON-25 / JBPAPP-3336 into EAP 5.2.0
Status: CLOSED DEFERRED
Alias: None
Product: JBoss Enterprise Application Platform 5
Classification: JBoss
Component: jbossas (Show other bugs)
(Show other bugs)
Version: 5.2.0
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Brad Maxwell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-04 12:20 UTC by Luan Cestari
Modified: 2018-12-04 15:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 20:23:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-10773 Major Closed MarshalledValueInputStream cannot load an array class from specified class loader 2014-04-16 14:12:23 UTC

Description Luan Cestari 2013-06-04 12:20:30 UTC
Description of problem:
Backport the JBCOMMON-25 /  JBPAPP-3336 into EAP 5.2.0

https://issues.jboss.org/browse/JBPAPP-3336
https://issues.jboss.org/browse/JBCOMMON-25

The change seems to be pretty small -> https://source.jboss.org/viewrep/JBossCommon/common-core/trunk/src/main/java/org/jboss/util/stream/MarshalledValueInputStream.java?r1=2044&r2=2415

The code of 5.2.0 doesn't have that : http://anonsvn.jboss.org/repos/jbossas/tags/JBPAPP_5_2_0_GA/server/src/main/org/jboss/invocation/MarshalledValueInputStream.java

Actual results:
When a client communicate with a server using EJB and with Java 6, the following execption occurs:
Caused by: java.lang.NoClassDefFoundError: IllegalName: [B
	at java.lang.ClassLoader.preDefineClass(ClassLoader.java:491)
        ...
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.loadClass(JNLPClassLoader.java:1574)
	at org.jboss.invocation.MarshalledValueInputStream.resolveClass(MarshalledValueInputStream.java:101)
	at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1609)


Expected results:
The communication should work.

Comment 2 Brad Maxwell 2013-06-10 20:23:51 UTC
EAP 5.x bugs are logged in jira not bz => https://issues.jboss.org/browse/JBPAPP-10773

Comment 3 JBoss JIRA Server 2013-08-23 04:35:09 UTC
Brad Maxwell <bmaxwell@redhat.com> updated the status of jira JBPAPP-10773 to Resolved

Comment 4 JBoss JIRA Server 2014-04-16 14:12:23 UTC
Jan Martiska <jmartisk@redhat.com> updated the status of jira JBPAPP-10773 to Closed


Note You need to log in before you can comment on or make changes to this bug.