Bug 970588 - [abrt] control-center-3.8.2-1.fc19: gcm_prefs_calib_apply_cb: Process /usr/bin/gnome-control-center was killed by signal 11 (SIGSEGV)
[abrt] control-center-3.8.2-1.fc19: gcm_prefs_calib_apply_cb: Process /usr/bi...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
abrt_hash:45d603cc49c9856fc1fe82d11f4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 08:22 EDT by Solomon Peachy
Modified: 2015-02-17 10:27 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:27:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.55 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: core_backtrace (3.57 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: dso_list (24.58 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: environ (1.46 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: maps (116.71 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: open_fds (1.04 KB, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-06-04 08:22 EDT, Solomon Peachy
no flags Details
File: var_log_messages (708 bytes, text/plain)
2013-06-04 08:23 EDT, Solomon Peachy
no flags Details

  None (edit)
Description Solomon Peachy 2013-06-04 08:22:24 EDT
Version-Release number of selected component:
control-center-3.8.2-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        gnome-control-center --overview
crash_function: gcm_prefs_calib_apply_cb
executable:     /usr/bin/gnome-control-center
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 gcm_prefs_calib_apply_cb at cc-color-panel.c:309
 #1 _g_closure_invoke_va at gclosure.c:840
 #4 on_assistant_apply at gtkassistant.c:799
 #5 _g_closure_invoke_va at gclosure.c:840
 #8 gtk_real_button_released at gtkbutton.c:1967
 #13 gtk_button_button_release at gtkbutton.c:1802
 #14 _gtk_marshal_BOOLEAN__BOXEDv at gtkmarshalers.c:130
 #15 _g_closure_invoke_va at gclosure.c:840
 #18 gtk_widget_event_internal at gtkwidget.c:6714
 #19 gtk_widget_event at gtkwidget.c:6371
Comment 1 Solomon Peachy 2013-06-04 08:22:29 EDT
Created attachment 756738 [details]
File: backtrace
Comment 2 Solomon Peachy 2013-06-04 08:22:33 EDT
Created attachment 756739 [details]
File: cgroup
Comment 3 Solomon Peachy 2013-06-04 08:22:37 EDT
Created attachment 756740 [details]
File: core_backtrace
Comment 4 Solomon Peachy 2013-06-04 08:22:41 EDT
Created attachment 756741 [details]
File: dso_list
Comment 5 Solomon Peachy 2013-06-04 08:22:45 EDT
Created attachment 756742 [details]
File: environ
Comment 6 Solomon Peachy 2013-06-04 08:22:49 EDT
Created attachment 756743 [details]
File: limits
Comment 7 Solomon Peachy 2013-06-04 08:22:52 EDT
Created attachment 756744 [details]
File: maps
Comment 8 Solomon Peachy 2013-06-04 08:22:56 EDT
Created attachment 756745 [details]
File: open_fds
Comment 9 Solomon Peachy 2013-06-04 08:22:59 EDT
Created attachment 756746 [details]
File: proc_pid_status
Comment 10 Solomon Peachy 2013-06-04 08:23:03 EDT
Created attachment 756747 [details]
File: var_log_messages
Comment 11 Knut-Håvard Aksnes 2013-07-28 13:10:30 EDT
This bug prevent color calibration for me, thus preventing serious photo work.
Comment 12 Matteo Nobili 2013-10-01 09:09:31 EDT
Same problem here. Everything worked flawlessly in Fedora 17, while in Fedora 19 I cannot calibrate my monitor with a Gretag-Macbeth AG - Eye-One display
This is the result of colormgr get-sensor-reading lcd :
Sensor: Gretag-Macbeth AG - Eye-One display
spotread exited unexpectedly
Comment 13 birger 2013-10-02 05:45:59 EDT
I have had 2 of these crashes in F20.

The first when I interrupted my first calibration run and tried to run again from the same control center instance.

The second after it failed (color calibration didn't prevent the screensaver from kicking in...) and I tried to start a new calibration.

I will try to work on the other screen this time around to see if it completes a run as long as I keep the screensaver busy.

My calibrator is a "ID 5986:0266 Acer, Inc"
Comment 14 Paul Finnigan 2013-11-05 05:18:23 EST
Similar problems with ColorMunki. I colord also crashed. I have raised a report https://bugzilla.redhat.com/show_bug.cgi?id=1026727 about this.
Comment 15 Paul Finnigan 2013-12-12 04:51:34 EST
I am now running 1.1.5-0.481.20131210git.fc20 of colord on a Beta release of Fedora 20. This problem still occurs using my colormunki after 973792 was fixed but only under specific circumstances.

If you attempt to calibrate you monitor then there are no problems. However if you attempt to recalibrate it then this problem occurs, until the USB cable is disconnected and then reconnected. After this it works.

This is true even if you just cancel out of the calibration process for any reason. To test it I started the calibration process until requested to put the colormunki on the screen. At this point I cancelled the calibration and immediately restarted it. 

The subsequent crash is shown as a duplicate of this bug by ABRT
Comment 16 David 2014-01-14 17:15:32 EST
This also is affecting me (directed here by ABRT).  Let me know if there is any additional information that i can add.
Comment 17 Gareth Williams 2014-02-01 11:04:15 EST
This was working of Fedora 20 Beta in December for me, but has failed this time.
Using a Huey Pro.
Comment 18 Chris Murphy 2014-03-25 17:27:17 EDT
colord-1.1.7-1.fc20.x86_64
gnome-color-manager-3.10.1-2.fc20.x86_64

Seems transient.


[ 7733.731113] usb 1-1.3: new low-speed USB device number 11 using ehci-pci
[ 7733.825446] usb 1-1.3: New USB device found, idVendor=0765, idProduct=d094
[ 7733.825458] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7733.825464] usb 1-1.3: Product: X-Rite DTP94
[ 7733.825468] usb 1-1.3: Manufacturer: X-Rite
[ 7733.825473] usb 1-1.3: SerialNumber: 026172
[ 7748.690827] gnome-control-c[6854]: segfault at 8 ip 000000000045bc57 sp 00007fffb4d550e0 error 4 in gnome-control-center[400000+372000]
Comment 19 birger 2014-04-03 05:29:44 EDT
Still does not work for me at all. If I restart a calibration it crashes. But even starting completely fresh the calibration always fails when nearing completion.

I have now tested on gnome 3.12 preview from the copr, and it is still the same.
Comment 20 Brian Morrison 2014-04-28 11:06:25 EDT
I am unable to calibrate my monitor in F20, I have all of the most recent control-centre, gnome-color-manager and colord packages, also the lcm2 and argyllcms packages too.

I am using a Color Munki Photo device, it is correctly recognised and the Calibrate button becomes active but clicking Done after the cal finishes leads to a crash and abrt launch.
Comment 21 Fedora End Of Life 2015-01-09 13:19:30 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 22 Fedora End Of Life 2015-02-17 10:27:17 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.