Bug 970628 - The installer doesn't activate a user account if a home directory for that user already exists
The installer doesn't activate a user account if a home directory for that us...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 09:26 EDT by Jiri Eischmann
Modified: 2013-06-11 23:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.30.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 23:38:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (30.87 KB, text/x-log)
2013-06-04 09:26 EDT, Jiri Eischmann
no flags Details

  None (edit)
Description Jiri Eischmann 2013-06-04 09:26:55 EDT
Created attachment 756787 [details]
Anaconda log

Description of problem:
If a home directory for a user account that is being created in Anaconda already, exists, Anaconda creates the account, but it's locked. Initial Experience wizard then doesn't find any user accounts, asks you to create one, but doesn't allow the same name because the account is already created, just locked.
While creating the user account, Anaconda returns: Error when creating new user: Error creating `/home/fedora': Soubor již existuje

How reproducible:
A new installation where you want to keep you existing /home partition.

Steps to Reproduce:
1. mount the existing /home partition as /home
2. create a new user account (that already has a home directory on the mounted partition) on the last screen of Anaconda.
3. finish the installtion process and reboot

Actual results:
The user account is locked in the newly installed system and the Initial Experience wizard asks you to create a new account. But you can't create an account with the name you want because it already exists.

Expected results:
Anaconda should not lock the account and connect it to the existing home directory on the mounted /home partition. A fresh installation with keeping a /home partition is a very common use case.

If Anaconda devel don't want to support this use case, the installer should at least inform the user that the account will be locked, or refuse to create it.

Additional info:
Comment 1 Kamil Páral 2013-06-04 10:31:26 EDT
If I understand this correctly, this behavior makes a system re-installation very unpleasant. Even if you have / and /home separated, you can't simply reformat / and mount /home. You either need to rename /home/user before installation and rename it back afterwards, or you need to create a different user during the installation and create the original user in the installed system. Both approaches are a bit cumbersome.

I believe this could be very well nominated for a FreezeException. Anaconda team, if you intend to fix this in F19, please nominate. Thank you.
Comment 2 Fedora Update System 2013-06-06 14:37:21 EDT
anaconda-19.30.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.3-1.fc19
Comment 3 Fedora Update System 2013-06-07 11:41:58 EDT
Package anaconda-19.30.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10283/anaconda-19.30.3-1.fc19
then log in and leave karma (feedback).
Comment 4 Jiri Eischmann 2013-06-10 07:14:21 EDT
Tested on TC2 and it works as intended.
Comment 5 Kamil Páral 2013-06-10 09:33:21 EDT
Setting verified per comment 4.
Comment 6 Fedora Update System 2013-06-11 23:38:19 EDT
anaconda-19.30.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.