Bug 97064 - Up2date fails to install glibc-common
Up2date fails to install glibc-common
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-09 16:11 EDT by Kenneth H. Riley
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-11 16:19:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth H. Riley 2003-06-09 16:11:23 EDT
Description of problem:
I am unable to install glibc-common and some other package updates using
up2date.  For example, when I enter "up2date -i"  I get a list of packages
available for my machine.  I select:

   glibc
   glibc-common
   glibc-devel

from the list.  After the Progress Dialog "Testing package set / solving
RPM inter-dependencies", I get a "WARNING!" box that says:

   Test install failed because of package conflicts:
   Installing package glibc-common-2.3.2-4.80.6 needs 3MB
   on the /usr/lib filesystem

I've gotten similiar messages for at least one other package that I tried
to update using up2date.  I know that I have plenty of space:

kenyatta~$ df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3               758968    360848    359564  51% /
/dev/sda2               101107     48987     46899  52% /boot
/dev/sda5              1035660    182804    800248  19% /home
none                     63264         0     63264   0% /dev/shm
/dev/sdc5               521748     16536    478708   4% /tmp
/dev/sdc3              1556716    402104   1091316  27% /usr
/dev/sdb3              1011960    312936    647616  33% /usr/src
/dev/sdc6              1252080   1013364    174056  86% /usr/lib
/dev/sdb6              1244048    887224    292568  76% /usr/share
/dev/sdc2              2056080   1533060    439484  78% /var

kenyatta~$ uname -a
Linux kenyatta.rileynet 2.4.20-18.8 #1 Thu May 29 07:50:46 EDT 2003 i586 i586
i386 GNU/Linux



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Kenneth H. Riley 2003-06-09 16:19:08 EDT
I forgot to enter the up2date version

kenyatta~$ up2date --nox --version
Red Hat Update Agent v3.0.7
Comment 2 Adrian Likins 2003-06-11 15:31:40 EDT
Those space calculations are from rpm, so reassigning to rpm.
Comment 3 Jeff Johnson 2003-06-11 16:19:58 EDT
Yup. glibc-common has lots and lots of hardlinks, like 120 Mb
worth. rpm does not attempt space caclulations taking into account
that members of a hardlink set don't take up additional space.

Easiest fix is to upgrade glibc-common (and whatever other packages
are needed) from the CLI using -Uvh, adding --ignoresize.

A real fix is gonna take longer, basically because of the length
of time needed to get an rpm release deployed.

Deferred until then

Note You need to log in before you can comment on or make changes to this bug.