Bug 970655 - JON Documentation Warning for long fields in UI
JON Documentation Warning for long fields in UI
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: GA
: JON 3.3.0
Assigned To: Jared MORGAN
Mike Foley
Jared MORGAN
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 09:59 EDT by Mike Thompson
Modified: 2015-08-09 21:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
No docs impact. Relates to translation limitations in the UI.
Last Closed: 2014-11-16 18:19:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Thompson 2013-06-04 09:59:23 EDT
Section Number and Name: 
This is mainly to document the constraint we have with:
Bundle Translation length issues

Describe the issue: 
On the d3 charts the right-hand min,max, avg label for chart legend is too long in German and overwrites the value; unfortunately, SVG text elements require a x,y coordinate (which makes it fixed) because this is vector based graphics with no rendering engine like html (although we do have a 100% width function).

We have room for probably about 6 characters after that we start pushing the label into overwriting the value and it doesn't look good. Obviously, if we use abbreviations in these fields if it is an issue. 

The specific message bundle keys I'm referring to here are 

Messages.properties:
chart_title_avg_label = Avg
chart_title_min_label = Min
chart_title_peak_label = Max

Suggestions for improvement:
Comment 1 Deon Ballard 2013-12-12 12:18:28 EST
I am reassigning this to the localization team.
Comment 2 Angela Garcia 2014-09-08 00:44:26 EDT
Hi All,

The use of abbreviations in some fields should be fine to work around this.
It would be ideal if a note to the translator can be included so that we all are aware of the issue.
Comment 3 Jared MORGAN 2014-11-11 23:05:59 EST
(In reply to Angela Garcia from comment #2)
> Hi All,
> 
> The use of abbreviations in some fields should be fine to work around this.
> It would be ideal if a note to the translator can be included so that we all
> are aware of the issue.

I'm not sure whether keeping this as a Documentation component is correct. It seems to relate to UI fields, therefore wouldn't the correct component be UI regardless of translation impact.
Comment 4 Mike Thompson 2014-11-12 10:39:29 EST
Of course the UI could always chop the field down but then the translator would be unaware of what they entered would get chopped and how far. This probably has different impacts in different languages (meaning 3 chars may be fine for english but not good enough for japanese). Also characters are misleading it should really, be pixels as other languages have symbols that are larger and its the pixel widths that push the limits not characters.

[This is getting rendered as SVG (on a graph) not HTML so we don't have all fancy things that we can do with HTML/CSS here.]

For these reasons, I do think it should be kept as a Documentation component.
Comment 5 Jared MORGAN 2014-11-12 18:14:31 EST
So we can keep it as a Documentation component, but as it is more documenting a limitation, can we close it off?

Or better still, document the issue/decision in a project workspace somewhere that the Translators and Engineers use so it doesn't get lost in BZ?
Comment 6 Mike Thompson 2014-11-13 17:55:00 EST
Oh sure. Close it.

Thanks Jared.
Comment 7 Jared MORGAN 2014-11-16 18:19:09 EST
Closing this off as NOTABUG, because it is more guidance for translators than an actual bug in the product.

Note You need to log in before you can comment on or make changes to this bug.