Bug 970662 - Hostgroup fields not populating when parent fields are selected
Hostgroup fields not populating when parent fields are selected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: jmagen@redhat.com
Corey Welton
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 10:13 EDT by Og Maciel
Modified: 2016-04-22 11:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cwelton: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 2616 None None None 2016-04-22 11:09 EDT

  None (edit)
Description Og Maciel 2013-06-04 10:13:35 EDT
Description of problem:

If I select a domain when creating a Hostgroup the subnet field does not become available for selection. But if I save, or attempt to save without entering a name, the field becomes selectable. Watching foreman/production.log shows 403s

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-ec2-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10002-44.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. As the foreman admin user create a new host group (the assumption is that you already have a smart proxy, domain, subdomain and content from Katello)
2.
3.

Actual results:

Some fields are not enabled after selecting values from the dropdowns (i.e. domain, operating system, etc)

Expected results:


Additional info:

Started GET "/foreman/foreman_katello_engine/activation_keys?environment_id=7" for 127.0.0.1 at 2013-06-04 09:41:39 -0400
Processing by HostgroupsController#environment_selected as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"2aMzo6DbPV6vgYHtNcPVPpb04gzGDAHqb/k5vAfWA5s=", "hostgroup"=>{"parent_id"=>"", "name"=>"qegroup2", "environment_id"=>"7", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "domain_id"=>"", "architecture_id"=>"", "root_pass"=>"[FILTERED]", "organization_ids"=>["", ""]}, "kt_activation_keys"=>"", "host_id"=>"null"}
Processing by ForemanKatelloEngine::ActivationKeysController#index as */*
  Parameters: {"environment_id"=>"7"}
  Rendered puppetclasses/_selectedClasses.html.erb (0.0ms)
  Rendered puppetclasses/_classes.html.erb (0.9ms)
  Rendered puppetclasses/_class_selection.html.erb (8.3ms)
Completed 200 OK in 17ms (Views: 10.6ms | ActiveRecord: 1.0ms)
Completed 200 OK in 672ms (Views: 0.3ms | ActiveRecord: 1.4ms)


Started POST "/foreman/hostgroups/domain_selected" for 127.0.0.1 at 2013-06-04 09:41:50 -0400
Processing by HostgroupsController#domain_selected as */*
  Parameters: {"domain_id"=>"3", "organization_id"=>"null"}
  Rendered common/404.html.erb within layouts/application (1.2ms)
Completed 404 Not Found in 94ms (Views: 4.3ms | ActiveRecord: 1.3ms)
Comment 1 Lukas Zapletal 2013-06-06 04:43:47 EDT
I can confirm with upstream.
Comment 2 Lukas Zapletal 2013-06-10 05:37:58 EDT
https://github.com/theforeman/foreman/pull/688
Comment 3 Brad Buckingham 2013-06-11 15:46:08 EDT
Mass move to ON_QA
Comment 4 Tazim Kolhar 2013-06-12 05:27:44 EDT
hi,

  please provide verification steps

thanks
Comment 5 jmagen@redhat.com 2013-06-12 05:44:53 EDT
The pull request is now https://github.com/theforeman/foreman/pull/693, not what was previously entere: https://github.com/theforeman/foreman/pull/688

Verification steps.

1) click new hostgroup
2) select parent id
3) the following 5 fields should automatically be populated based on the parents info (assuming it exists)

+    @hostgroup.architecture      
+    @hostgroup.operatingsystem  
+    @hostgroup.domain           
+    @hostgroup.subnet          
+    @hostgroup.environment
Comment 6 Corey Welton 2013-06-12 16:33:53 EDT
poaching this bz since I'm here in this part of the code already.
Comment 7 Corey Welton 2013-06-12 16:34:43 EDT
QE Verified.  The aforementioned fields in comment #6 now get autopopulated.

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10009-1.noarch
* foreman-compute-1.1.10009-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10009-1.noarch
* foreman-postgresql-1.1.10009-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-12.el6sat.noarch
* katello-all-1.4.2-12.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-12.el6sat.noarch
* katello-configure-1.4.3-15.el6sat.noarch
* katello-configure-foreman-1.4.3-15.el6sat.noarch
* katello-foreman-all-1.4.2-12.el6sat.noarch
* katello-glue-candlepin-1.4.2-12.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-12.el6sat.noarch
* katello-glue-pulp-1.4.2-12.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch
Comment 8 Mike McCune 2013-07-18 17:19:30 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.