Bug 970667 - vdsm-reg UI integration re-write
vdsm-reg UI integration re-write
Status: CLOSED DUPLICATE of bug 994451
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Douglas Schilling Landgraf
Artyom
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 10:35 EDT by Alon Bar-Lev
Modified: 2016-02-10 14:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 14:56:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17682 None None None Never

  None (edit)
Description Alon Bar-Lev 2013-06-04 10:35:25 EDT
ovirt-node of 3.3 introduces a complete new UI framework.

A new implementation of user interaction should be written, disconnecting the implementation from vdsm-reg.

UI DESIGN

oVirt Engine Registration

    Engine Host: _____________________
    Engine Port: _____443_____________
[x] Use SSL
[x] Engine is >= 3.2 (may be not required if we can detect this automatically)
[ ] Ignore current CA trust

    [OK]    [CANCEL]

Enable SSH user/password Access

[ ] Enable ssh password access.
    Password: ____________
    Repeat:   ____________

    [OK]    [CANCEL]

IMPLEMENTATION DETAILS

 * No fallback to http, protocol is explicitly selected.
 * If engine is >= 3.2 do not execute vdsm-reg but perform registration directly.
 * If ignore current CA trust download CA certificate and present fingerprint even if CA already exist.
 * Separate the tabs between engine registration and ssh access.

TECHNICAL DETAILS

 * Modular clean implementation.
 * Conventions similar to ovirt-host-deploy.
Comment 1 Alon Bar-Lev 2013-08-16 16:52:18 EDT
I recommend not to move to post until will be somewhat ready.
Comment 2 Alon Bar-Lev 2013-08-18 14:56:01 EDT

*** This bug has been marked as a duplicate of bug 994451 ***

Note You need to log in before you can comment on or make changes to this bug.