Bug 970674 - OpenStack Installer: packstack get stuck when trying to add an additional compute node, using a white-space to separate between IP Addresses
OpenStack Installer: packstack get stuck when trying to add an additional com...
Status: CLOSED DUPLICATE of bug 961390
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Linux
unspecified Severity high
: ---
: 4.0
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 10:49 EDT by Nir Magnezi
Modified: 2013-06-04 11:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 11:41:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Magnezi 2013-06-04 10:49:09 EDT
Description of problem:
=======================
I tried to add additional compute node to an all-in-one installation via packstack.
packstack got stuck with some kind of quantum related issue.
apparently, it happened because of the white-space between IP Addresses:
CONFIG_NOVA_COMPUTE_HOSTS=<IP Address A>, <IP Address B>

Version-Release number of selected component (if applicable):
=============================================================
openstack-packstack-2013.1.1-0.7.dev580.el6ost.noarch

How reproducible:
=================
2/2

Steps to Reproduce:
===================
1. install openstack all-in-one via packstack
2. add additional compute node using packstack answers file as described in Description of problem

Actual results:
===============
packstack gets stuck with the following DEBUG in it's log:

2013-06-04 17:34:41::DEBUG::shell::61::root:: # ============ ssh : None ==========
2013-06-04 17:34:41::DEBUG::shell::75::root:: scp -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@<HOST>:/var/tmp/packstack/f705b0edf2f941d797a8960cd5738462/manifests/ <HOST>_quantum.pp.finished /var/tmp/packstack/20130604-160230-vOvCcq/manifests/ <HOST>_quantum.pp.log
2013-06-04 17:34:41::DEBUG::shell::78::root:: ============ STDOUT ==========

Expected results:
=================
Should be installed with no issues.
Comment 2 Martin Magr 2013-06-04 11:41:07 EDT

*** This bug has been marked as a duplicate of bug 961390 ***

Note You need to log in before you can comment on or make changes to this bug.