Bug 970685 - Exception org.exoplatform.portal.webui.page.PageModel not serializable thrown when accessing administration/pageManagement page
Exception org.exoplatform.portal.webui.page.PageModel not serializable thrown...
Status: CLOSED NOTABUG
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 11:17 EDT by Dominik Pospisil
Modified: 2013-11-04 19:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 08:45:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-2964 Major Resolved NSE thrown when accessing Page Management 2013-06-18 03:10:58 EDT

  None (edit)
Description Dominik Pospisil 2013-06-04 11:17:54 EDT
Description of problem:

The exception org.infinispan.marshall.NotSerializableException: Type TypeModel[name=org.exoplatform.portal.webui.page.PageModel] is not serializable is thrown when accessing administration/pageManagement page.


Version-Release number of selected component (if applicable):
JPP 6.1.0.ER1

How reproducible:
Allways

Steps to Reproduce:
1. log-it to portal
2. access /portal/g/:platform:administrators/administration/pageManagement
3.



Additional info:
17:12:52,313 ERROR [org.infinispan.interceptors.InvocationContextInterceptor] (http-/127.0.0.1:8080-2) ISPN000136: Execution error: org.infinispan.marshall.NotSerializableException: Type TypeModel[name=org.exoplatform.portal.webui.page.PageModel] is not serializable                                                                                                                                                                  
Caused by: an exception which occurred:                                                                                                                                                                               







17:12:52,317 ERROR [org.infinispan.transaction.TransactionCoordinator] (http-/127.0.0.1:8080-2) ISPN000188: Error while processing a commit in a two-phase transaction: org.infinispan.marshall.NotSerializableException: Type TypeModel[name=org.exoplatform.portal.webui.page.PageModel] is not serializable                                                                                                                              
Caused by: an exception which occurred:                                                                                                                                                                               




        in object org.infinispan.container.entries.ImmortalCacheEntry@ebbc6de1
        in object org.infinispan.loaders.bucket.Bucket@269b6a0f

17:12:52,318 ERROR [org.infinispan.transaction.tm.DummyTransaction] (http-/127.0.0.1:8080-2) ISPN000111: afterCompletion() failed for SynchronizationAdapter{localTransaction=LocalTransaction{remoteLockedNodes=null, isMarkedForRollback=false, lockedKeys=null, backupKeyLocks=null, topologyId=-1, isFromStateTransfer=false} org.infinispan.transaction.synchronization.SyncLocalTransaction@80} org.infinispan.transaction.synchronization.SynchronizationAdapter@9f: org.infinispan.CacheException: Could not commit.
        at org.infinispan.transaction.synchronization.SynchronizationAdapter.afterCompletion(SynchronizationAdapter.java:83)
        at org.infinispan.transaction.tm.DummyTransaction.notifyAfterCompletion(DummyTransaction.java:285)
        at org.infinispan.transaction.tm.DummyTransaction.runCommitTx(DummyTransaction.java:334)
        at org.infinispan.transaction.tm.DummyTransaction.commit(DummyTransaction.java:91)
        at org.infinispan.transaction.tm.DummyBaseTransactionManager.commit(DummyBaseTransactionManager.java:102)
        at org.jboss.as.clustering.web.impl.TransactionBatchingManager.endBatch(TransactionBatchingManager.java:75)
        at org.jboss.as.web.session.DistributableSessionManager.processSessionRepl(DistributableSessionManager.java:1535) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.DistributableSessionManager.storeSession(DistributableSessionManager.java:865) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.InstantSnapshotManager.snapshot(InstantSnapshotManager.java:47) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.ClusteredSessionValve.handleRequest(ClusteredSessionValve.java:142) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.ClusteredSessionValve.invoke(ClusteredSessionValve.java:99) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.JvmRouteValve.invoke(JvmRouteValve.java:92) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.as.web.session.LockingValve.invoke(LockingValve.java:64) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.gatein.sso.integration.SSODelegateValve.invoke(SSODelegateValve.java:159) [sso-integration-1.3.3.CR03.jar:1.3.3.CR03]
        at org.gatein.portal.security.jboss.PortalClusteredSSOSupportValve.invoke(PortalClusteredSSOSupportValve.java:88) [exo.portal.component.web.security-jboss-3.6.0.Beta02-prod-SNAPSHOT.jar:3.6.0.Beta02-prod-SNAPSHOT]
        at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920) [jbossweb-7.2.0.Final-redhat-1.jar:7.2.0.Final-redhat-1]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_19]
Caused by: javax.transaction.xa.XAException
        at org.infinispan.transaction.TransactionCoordinator.handleCommitFailure(TransactionCoordinator.java:224)
        at org.infinispan.transaction.TransactionCoordinator.commit(TransactionCoordinator.java:185)
        at org.infinispan.transaction.synchronization.SynchronizationAdapter.afterCompletion(SynchronizationAdapter.java:81)
        ... 23 more
Comment 1 Thomas Heute 2013-06-06 08:45:30 EDT
Was fixed in ER01 already

Note You need to log in before you can comment on or make changes to this bug.