Bug 970692 - fakeroot fails to build for aarch64
Summary: fakeroot fails to build for aarch64
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fakeroot   
(Show other bugs)
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-04 15:38 UTC by Mark Salter
Modified: 2013-08-09 17:08 UTC (History)
2 users (show)

Fixed In Version: fakeroot-1.18.4-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 22:12:18 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config update for aarch64 builds (43.08 KB, patch)
2013-06-04 15:38 UTC, Mark Salter
no flags Details | Diff

Description Mark Salter 2013-06-04 15:38:43 UTC
Created attachment 756848 [details]
config update for aarch64 builds

Description of problem:
fakeroot fails to build for aarch64 because aarch64 is not recognized by fakeroot's version config.{sub,guess}. RPM would update these config files automatically but only if the package uses %configure instead of invoking configure directly. Fakeroot does use %configure but unfortunately, from a subdir with the config.{sub,guess} files at the top level. This causes rpm to not see them and so no update occurs.

The attached patch updates the config files to newer versions which recognize aarch64.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2013-07-27 04:47:35 UTC
fakeroot-1.18.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fakeroot-1.18.4-1.fc19

Comment 2 Fedora Update System 2013-07-27 04:47:54 UTC
fakeroot-1.18.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fakeroot-1.18.4-1.fc18

Comment 3 Fedora Update System 2013-07-28 01:10:13 UTC
Package fakeroot-1.18.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fakeroot-1.18.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13762/fakeroot-1.18.4-1.fc19
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-08-02 22:12:18 UTC
fakeroot-1.18.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2013-08-09 17:08:01 UTC
fakeroot-1.18.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.