Bug 97070 - Default install of sshd allows root login
Summary: Default install of sshd allows root login
Keywords:
Status: CLOSED DUPLICATE of bug 89216
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-09 21:30 UTC by Darren Gamble
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-24 07:41:00 UTC


Attachments (Terms of Use)

Description Darren Gamble 2003-06-09 21:30:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
The default sshd_config file included in the package allows the root user to log
in ("PermitRootLogin" is not "no").



Version-Release number of selected component (if applicable):
openssh-server-3.5p1-6

How reproducible:
Always

Steps to Reproduce:
1. Attempt to ssh in as root to a machine with a default sshd install

    

Actual Results:  The login is accepted.

Expected Results:  The login should have been denied.

Additional info:

This appears to also have been the case with various versions of Red Hat in the
past.

It can be debated whether this actually a bug or not, but for a product that's
supposedly secure out of the box, a root ssh login really should be disabled by
default.

Comment 1 Peter van Egdom 2003-06-10 20:29:19 UTC
This is a duplicate bug report. See Red Hat Bugzilla Bug 89216.

Comment 2 Mark J. Cox 2003-06-11 08:06:07 UTC

*** This bug has been marked as a duplicate of 81296 ***

Comment 3 Darren Gamble 2003-06-11 15:03:20 UTC
Bug# 81296 has nothing to do with this problem.  Perhaps you meant to mark that
bug as a duplicate of bug# 89527?

Comment 4 Tomas Mraz 2005-10-24 07:39:40 UTC

*** This bug has been marked as a duplicate of 89216 ***


Note You need to log in before you can comment on or make changes to this bug.