Bug 970703 - [RFE] some sort of katello-foreman-libvirt optional packaging for configuring libvirt-based provisioning
[RFE] some sort of katello-foreman-libvirt optional packaging for configuring...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
RFE
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 12:06 EDT by Corey Welton
Modified: 2017-02-09 15:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-09 15:52:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-06-04 12:06:51 EDT
Description of problem:
Simply put, the current process to setup libvirt so that a user can use it in conjunction with foreman is completely arduous.  Installing a bunch of virtualization, DHCP, TFTP packages and manually creating the files for foreman's consumption -- it's very, very error-prone.  

At the same time, I can see where users may not want to use the libvirt option, opting for baremetal, and doesn't want all the dependencies or cruft that might come with stuff they'd never use.

Thus, I think we should have a package set -- "katello-foreman-libvirt" or something that has dependencies on all those aforementioned, required packages and installs at least usable, skeleton versions of the required config files that would give users a "quickstart" to get them up and running, which they could tweak later (i.e., change subnets, etc.) if they so desired.


Requires:
@virtualization
libvirt
tftp
[...]

Creates and/or correctly populates:
/etc/libvirt/qemu/networks/foreman.xml
/etc/libvirt/storage/default-pool.xml
/etc/dhcp/dhcpd.conf
[...]


...and so on.
Comment 1 Mike McCune 2013-06-06 13:02:38 EDT
amen :)
Comment 4 Corey Welton 2013-06-24 10:40:47 EDT
One more consideration for this bug - the ISO installer currently only installs katello-foreman-all, which does not pull in foreman-libvirt. If this stuff is abstracted out, the installer will need to provide option to install product with or without libvirt support, and as such, install the package (or not).
Comment 9 Mike McCune 2013-11-01 16:34:38 EDT
this is really solved  by:

https://github.com/domcleal/katellovirt

can be used by:

# puppet module install domcleal/katellovirt
# puppet apply -v -e 'include katellovirt'

the question is: "How do we support this?"

For MDP we can point users at this method but we will need a way to install and ship that puppet module and perhaps have an option on kafo to set this up.

I'm going to move this to MDP3 so we can figure out a *right* way to do this and for MDP2 we can use the above 2 liner to get things setup.
Comment 10 Todd Warner 2017-02-09 15:52:00 EST
Due to the age of this request, and our prioritization, I am closing this bugzilla. The prioritization ensured that it was not something we could ever address in a meaningful timeframe.

-todd warner, PM, Satellite

Note You need to log in before you can comment on or make changes to this bug.