Bug 970719 - initial-setup-text.service causes endless lvm messages to the console
initial-setup-text.service causes endless lvm messages to the console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
19
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: ARMTracker F19-accepted/F19FinalFreezeException F19ARMBlocker
  Show dependency treegraph
 
Reported: 2013-06-04 13:06 EDT by Paul Whalen
Modified: 2013-06-23 02:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: initial-setup-0.3.6-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 02:25:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-06-04 13:06:03 EDT
Description of problem:

initial-setup-text.service causing endless lvm messages to the console. 


Version-Release number of selected component (if applicable):

initial-setup-0.3.5-1.fc19

How reproducible:
Everytime.

Steps to Reproduce:
1. Boot F19 Beta on any ARM system. Install intial-setup
2. enable initial-setup-text.service, will display lvm messages.
3. reboot the system, console will display endless messages:

Actual results:

System displays endless messages when rebooted:
[  253.711495] LVM: Logical Volume autoactivation enabled.
[  253.717464] LVM: Activation generator successfully completed.

Will not run intial-setup-text.service.

Expected results:
System boots into initial-setup-text.service

Additional info:
Comment 1 Peter Rajnoha 2013-06-06 03:41:29 EDT
(In reply to Paul Whalen from comment #0)
> System displays endless messages when rebooted:
> [  253.711495] LVM: Logical Volume autoactivation enabled.
> [  253.717464] LVM: Activation generator successfully completed.

These messages are meant just for signalling that the lvm2-activation-generator (found in /lib/systemd/system-generators dir) completed successfully which is an important debug information for us if something would go wrong with this activation. In this case, the generator just says that LVM autoactivation is enabled and so the generator has nothing to do as volumes will be autoactivated using udev events and so we don't need to generate systemd units on-the-fly to activate the LVM volumes directly. Based on this debug information, we know exactly how LVM volumes are activated on boot...

These messages are normally seen on console only if "quiet" option is not used on kernel cmd line (stock Fedora releases use it). They're seen only in /var/log/messages or systemd journal otherwise.

Systemd reinitializes all its generators on its reload (e.g. systemctl daemon-reload). It seems systemd is reloaded way too often for some reason? As a consequence, the generator is fired that many times. Maybe try running systemd in debug mode and see if systemd provides some more details about the problem by adding these options to your kernel cmd line:

   systemd.log_target=console systemd.log_level=debug
Comment 2 Peter Rajnoha 2013-06-06 03:48:20 EDT
(In reply to Peter Rajnoha from comment #1)
> Systemd reinitializes all its generators on its reload (e.g. systemctl
> daemon-reload).

...see also http://www.freedesktop.org/wiki/Software/systemd/Generators/ and
note #3 under "A couple of notes" paragraph.
Comment 3 Vratislav Podzimek 2013-06-13 08:56:44 EDT
Any idea what can be done here? I have no idea why these messages are printed out. The initial-setup-text.service includes this:

ExecStartPre=/bin/kill -55 1
ExecStart=/bin/initial-setup
ExecStartPost=/bin/kill -54 1

Which should (according to 'man systemd') prevent systemd from printing messages to console. So if this really is a bug, it is a systemd bug.
Comment 4 Paul Whalen 2013-06-13 10:45:54 EDT
Systemd appears to be reloading which is causing the lvm messages on the console, we currently do not include 'quiet' in the boot args which is easily remedied. 

Ignoring the console messages, intial-setup-text is not run on the serial console when the system is booted, and appears to try to use tty1 which is less than ideal for systems lacking display.
Comment 5 Vratislav Podzimek 2013-06-17 09:13:49 EDT
(In reply to Paul Whalen from comment #4)
> Systemd appears to be reloading which is causing the lvm messages on the
> console, we currently do not include 'quiet' in the boot args which is
> easily remedied. 
> 
> Ignoring the console messages, intial-setup-text is not run on the serial
> console when the system is booted, and appears to try to use tty1 which is
> less than ideal for systems lacking display.
I've just tested the I-S with 'console=ttyS0' as a boot option and it ran on the serial console. The problem was that systemd killed it and continued with the boot. Probably because of the I-S's service having just 'Before=display-manager.service getty@tty1.service' which doesn't cover ttyS0.
Comment 6 Vratislav Podzimek 2013-06-18 08:21:15 EDT
A patch that should fix the issues with serial console pushed to master. I've done some testing of it and it seems to be working right for me.
Comment 7 Fedora Update System 2013-06-18 14:54:35 EDT
initial-setup-0.3.6-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/initial-setup-0.3.6-2.fc19
Comment 8 Fedora Update System 2013-06-19 09:09:55 EDT
Package initial-setup-0.3.6-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initial-setup-0.3.6-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11276/initial-setup-0.3.6-2.fc19
then log in and leave karma (feedback).
Comment 9 Adam Williamson 2013-06-19 14:06:12 EDT
Discussed at 2013-06-19 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-19/f19final-blocker-review-7.2013-06-19-16.01.log.txt . As we understand it this change is required to make our planned ARM workflow for F19 work (we need i-s text to work to set up root pw, user account on pre-built non-graphical ARM images). So accepted as a freeze exception issue as a 'showstopper' for a secondary arch.
Comment 10 Fedora Update System 2013-06-23 02:25:58 EDT
initial-setup-0.3.6-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.