Bug 970745 - Orca sometimes announce "missspelled" with every keystroke.
Orca sometimes announce "missspelled" with every keystroke.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: orca (Show other bugs)
rawhide
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 14:33 EDT by chrys87
Modified: 2013-06-08 15:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 15:45:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chrys87 2013-06-04 14:33:55 EDT
Description of problem:
I use the gnome-shell with the screenreder orca.
for my work i need libreoffice.
If i write an document, orca doesnt speak the first wordi write on an empty document.

Version-Release number of selected component (if applicable):
Orca 3.8.1.
LibreOffice 4.0.0.beta1.fc19

How reproducible:
Run Orca-> enable "echo per word" in preferences -> open writer and type.

Steps to Reproduce:
1. run orca with alt+f2 -> type "orca" -> hit enter OR enable screenreader over the gnome accessibility menue
2.go into orca preferences wit CAPSLOCK + Space (on laptop) or INSERT + SPACE on PC
3.Goto Page "Keyboard echo"(Tastaturecho in german) -> Enable Echo per Word (i dont know if it matters, but i do so)
4. Press OK
5 Start LibreOffice Writer
6 Type Correct and Incorrect words mixed and navigate arround

Actual results:
Sometimes Orca Say: "missspell" with every keystroke (doesnt matter if the current word is correct or not)
after press return a view times it goes back to normal processing

Expected results:
Orca should always only say "misspelled" on incorrect words. 


Additional info:
I use an german Setup with espeak as speechsyntezier.
Comment 1 Joanmarie Diggs 2013-06-08 15:44:49 EDT
Unlike other distros which tend to mix-and-match packages, Fedora stays close to upstream (which is why I love it). As a result, it is extremely unlikely that an Orca bug is a Fedora-only bug. In the future please file these bugs upstream.

I have since copied and pasted the opening report here:
https://bugzilla.gnome.org/show_bug.cgi?id=701874

Someone with privs to close this bug should do so. Thanks!

Note You need to log in before you can comment on or make changes to this bug.