Bug 970774 - [RFE] As a headpin user, I do not like to see Environment Selector in distributor creation
[RFE] As a headpin user, I do not like to see Environment Selector in distrib...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
: FutureFeature
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-04 16:25 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:11:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 10:43:14 EDT

  None (edit)
Description sthirugn@redhat.com 2013-06-04 16:25:29 EDT
Description of problem:
[RFE] As a headpin user, I do not like to see Environment Selector in distributor creation

Version-Release number of selected component (if applicable):
* candlepin-0.8.12-1.el6.noarch
* candlepin-cert-consumer-hp-dl385g5p-01.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.12-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.73.f7d6d0c.el6.noarch
* katello-cli-common-1.4.2-1.git.73.f7d6d0c.el6.noarch
* katello-common-1.4.2-1.git.535.aafed33.el6.noarch
* katello-configure-1.4.3-1.git.51.c5aa3be.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.535.aafed33.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.535.aafed33.el6.noarch
* katello-headpin-1.4.2-1.git.535.aafed33.el6.noarch
* katello-headpin-all-1.4.2-1.git.535.aafed33.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch


How reproducible:
N/A

Steps to Reproduce:
1. Log into headpin Web UI
2. Navigate to Subscriptions -> Subscription Manager Applications -> Click + New Distributor


Actual results:
Notice that Enviroment selector is shown defaulting to Library

Expected results:
Environment selector should be hidden as Environments are not applicable in headpin mode anymore

Additional info:
Comment 1 Tom McKay 2013-07-18 16:11:36 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: a58276b0c3570848ecab63cd43e5557b21c18d8e
      https://github.com/Katello/katello/commit/a58276b0c3570848ecab63cd43e5557b21c18d8e
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-17 (Wed, 17 Jul 2013)
Comment 2 Bryan Kearney 2013-08-02 14:51:47 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 3 sthirugn@redhat.com 2013-08-12 17:42:58 EDT
VERIFIED

Packages tested:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 5 errata-xmlrpc 2013-10-01 07:11:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.