Bug 970788 - speech-dispatcher run with 100% cpu load after login while orca was enabled in gdm
speech-dispatcher run with 100% cpu load after login while orca was enabled i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: speech-dispatcher (Show other bugs)
20
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
: 1091147 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 17:40 EDT by chrys87
Modified: 2015-03-31 17:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: speech-dispatcher-0.8.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-23 03:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Speech-dispatcher 0.7 : fix high cpu usage at output module disconnection (719 bytes, patch)
2013-09-08 05:44 EDT, Gilles Casse
no flags Details | Diff

  None (edit)
Description chrys87 2013-06-04 17:40:09 EDT
Description of problem:
I run orca because i m blind.
So i enable orca in GDM and in the Gnome-Session.
After Login i have in the audio settings (applications tab)  2 times the speech-dispatcher stream.
if i look with top, one of the speech-dispatcher processes have the UID gdm and the other the id of my user.
The instance of the GDM have 100% cpu load.
cause of this my fan runs and runs and runs :/

Version-Release number of selected component (if applicable):
orca 3.8.1
speech-dispatcher 0.7.1


How reproducible:
1.enable orca (the screenreader) over the accessibility menu in gdm
2.enable the screenreader over the accessibility menu in the usersession
3.make sure that espeak works with orca and speech-dispatcher
4.reboot
5.after boot -> orca came up and read the loginscreen
6.LOGIN
7.after login orca came up with your usersession.

Actual results:
After login the speech-dispatcher process of the user GDM runs with 100 percent load
And the speech-dispatcher for the user runs normal.

Expected results:
only the speech-dispatcher of the user runs

Additional info:
Dell vostro 3360 with core i7
after i kill the wrong speech-dispatcher process everything runs normal
Comment 1 paul59584 2013-06-22 20:32:04 EDT
I also see this. 100% cpu use by speech-dispatcher (1 core). I don't need orca (but would like to be able to use it ocassionally) so have uninstalled it for now and problem has stopped.
Comment 2 chrys87 2013-06-23 10:22:52 EDT
I see this not only happens in GDM (but in my case if gdm starts with orca, there is 100 % load), this also happens in reguler use. for example if i surf the net with firefox.
Comment 3 Janina Sajka 2013-07-08 20:28:11 EDT
On my I7 X86_64, load ramps quickly from approx 1.0 to over 2.0, but only after Orca is started.
Comment 4 Fedora Update System 2013-08-07 04:03:49 EDT
speech-dispatcher-0.8-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8-3.fc19
Comment 5 Fedora Update System 2013-08-07 18:58:39 EDT
Package speech-dispatcher-0.8-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing speech-dispatcher-0.8-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14393/speech-dispatcher-0.8-3.fc19
then log in and leave karma (feedback).
Comment 6 Peter Robinson 2013-08-12 22:09:37 EDT
@chris can you please provide more debug. Ultimately -1 karma on a package update needs further debug. Ultimately if it doesn't fix the problem but doesn't regress the problem we need to move to the newer version and do debug there because upstream no longer support this current release and we need to do debug against the latest release. If we can't do that we can't fix this bug and I'll close it won't fix
Comment 7 Gilles Casse 2013-09-08 05:44:19 EDT
Created attachment 795318 [details]
Speech-dispatcher 0.7 : fix high cpu usage at output module disconnection

This issue is observed with speech dispatcher 0.7 or 0.8.

For end users wishing to try it out, we propose already patched packages [1].

This patch is currently proposed upstream for speech dispatcher 0.8 [2].

[1] http://soft.oralux.net/speech-dispatcher/install_fix_high_cpu_usage/fedora/19/install_fix_high_cpu_usage.tgz

[2] http://lists.freebsoft.org/pipermail/speechd/2013q3/004468.html
Comment 8 chrys87 2013-09-09 10:46:58 EDT
(In reply to Gilles Casse from comment #7)
> Created attachment 795318 [details]
> Speech-dispatcher 0.7 : fix high cpu usage at output module disconnection
> 
> This issue is observed with speech dispatcher 0.7 or 0.8.
> 
> For end users wishing to try it out, we propose already patched packages [1].
> 
> This patch is currently proposed upstream for speech dispatcher 0.8 [2].
> 
> [1]
> http://soft.oralux.net/speech-dispatcher/install_fix_high_cpu_usage/fedora/
> 19/install_fix_high_cpu_usage.tgz
> 
> [2] http://lists.freebsoft.org/pipermail/speechd/2013q3/004468.html

I tested you patched propose in [1]. Looks good :) and work as exept for me. I hope the upstream get fixed soon :).
Comment 9 chrys87 2013-12-09 03:03:24 EST
This Problem still appear in Fedora 20 Beta + Updates
Comment 10 chrys87 2013-12-19 01:37:52 EST
also in F20.
It seems that Gilles patches doesnt apply by the upstream :/
Comment 11 Peter Robinson 2014-08-29 05:39:30 EDT
*** Bug 1091147 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2015-03-20 11:06:25 EDT
speech-dispatcher-0.8.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc20
Comment 13 Fedora Update System 2015-03-20 11:06:42 EDT
speech-dispatcher-0.8.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc21
Comment 14 Fedora Update System 2015-03-20 11:06:53 EDT
speech-dispatcher-0.8.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/speech-dispatcher-0.8.2-1.fc22
Comment 15 Fedora Update System 2015-03-22 00:28:20 EDT
Package speech-dispatcher-0.8.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing speech-dispatcher-0.8.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4357/speech-dispatcher-0.8.2-1.fc22
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2015-03-23 03:16:16 EDT
speech-dispatcher-0.8.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-03-31 17:39:38 EDT
speech-dispatcher-0.8.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-03-31 17:40:56 EDT
speech-dispatcher-0.8.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.