Bug 970820 - Update cloud-init on cloud image to support config disk
Update cloud-init on cloud image to support config disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: guest-images (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: pre-dev-freeze
: ---
Assigned To: Joey Boggs
yeylon@redhat.com
: DevelBlocker, TestOnly
Depends On: 968246
Blocks: 883504
  Show dependency treegraph
 
Reported: 2013-06-04 21:54 EDT by Greg Padgett
Modified: 2016-06-12 19:17 EDT (History)
16 users (show)

See Also:
Fixed In Version: rhel-guest-image-6-6.5-20131008.0.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 19:21:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1735 normal SHIPPED_LIVE rhel-guest-image bug fix and enhancement update 2013-11-20 17:04:16 EST

  None (edit)
Description Greg Padgett 2013-06-04 21:54:54 EDT
Description of problem:
oVirt would like to be able to boot the cloud image as-is and use cloud-init to set up the vm.  Instead of using a metadata service, oVirt uses an attached config disk; however, the current cloud-init version won't discover attached config disks on systems with 2.6 kernels.  (blkid needs some prodding to scan /dev/srX)

Note that this is dependent upon a pending cloud-init fix at:
https://code.launchpad.net/~gpadgett/cloud-init/dev-sr-fix


Version-Release number of selected component (if applicable):
rhel-server-x86_64-kvm-6.4_20130130.0-4.qcow2

How reproducible:
Always

Steps to Reproduce:
1. Boot image using ovirt with attached cloud-init config cd
2.
3.

Actual results:
Config disk not discovered

Expected results:
Disk found, processed by cloud-init

Additional info:
Comment 2 Mike Burns 2013-06-05 07:54:42 EDT
Is this needed in 6.4.z as well? or just 6.5?
Comment 3 Steven Hardy 2013-06-05 08:16:16 EDT
(In reply to Mike Burns from comment #2)
> Is this needed in 6.4.z as well? or just 6.5?

I believe (unless we backport this change to the 0.7.1 cloud-init package, which I'd rather not do) this should be addressed as part of bug #968246 which aims to update to a 0.7.2 based package for EL 6.5.

I believe the boto version change (which changes the interfaces to AWS v4 signature format by default) discussed under #968246 and #968247 will prevent us from doing a 6.4.z release of this change?
Comment 4 Mike Burns 2013-06-05 08:31:01 EDT
If this is only going into a cloud-init that is available starting in 6.5, then it's TestOnly from guest-images perspective.  

If it's going to get backported or handled somehow in 6.4.z, then please let me know.
Comment 5 Itamar Heim 2013-06-09 16:02:55 EDT
(In reply to Mike Burns from comment #2)
> Is this needed in 6.4.z as well? or just 6.5?

6.5 is good enough, but how soon can we get an image to work with as we need to integrate and test with it in the coming month or so?
Comment 6 Mike Burns 2013-06-10 09:21:07 EDT
(In reply to Itamar Heim from comment #5)
> (In reply to Mike Burns from comment #2)
> > Is this needed in 6.4.z as well? or just 6.5?
> 
> 6.5 is good enough, but how soon can we get an image to work with as we need
> to integrate and test with it in the coming month or so?

That depends on getting the new cloud-init packaged and built.  I've set that bug to be required by pre-dev-freeze and set the Layered Products to RHEV and OpenStack.
Comment 23 Lubos Kocman 2013-10-31 19:12:29 EDT
Hello,

I only did the same as in any previous compose which is to use build from rhui-2-ec2-rhel-6-candidate.

This was initial configuration for appliance images and I just kept using that.


$ brew latest-pkg RHEL-6.5-RC-1-set cloud-init --quiet
cloud-init-0.7.1-2.el6                    RHEL-6.5-RC-1-set     apevec
$ brew latest-pkg rhui-2-ec2-rhel-6-candidate cloud-init --quiet
cloud-init-0.7.1-2.el6                    rhui-2-ec2-rhel-6-candidate  apevec

If you want to use some separate tag for yourself then I have nothing against it. But then you'll have to guarantee me that it gets into standardized tag that I'm using for the compose.
Comment 26 Wei Shi 2013-11-03 08:17:23 EST
Verified:
  rhel-guest-image-6-6.5-20131101.2-1-sda.qcow2

# guestfish --ro -i -a rhel-guest-image-6-6.5-20131101.2-1-sda.qcow2 inspect-list-applications /dev/sda1 

...
[16] = {
  app_name: cloud-init
  app_display_name: 
  app_epoch: 0
  app_version: 0.7.2
  app_release: 2.el6
  app_install_path: 
  app_trans_path: 
  app_publisher: 
  app_url: 
  app_source_package: 
  app_summary: 
  app_description: 
}
...
Comment 29 errata-xmlrpc 2013-11-21 19:21:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1735.html

Note You need to log in before you can comment on or make changes to this bug.