Bug 970825 - remote-viewer should add introduction for new added functions into man page and help info.
remote-viewer should add introduction for new added functions into man page a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On:
Blocks: 1083786
  Show dependency treegraph
 
Reported: 2013-06-04 22:22 EDT by Geyang Kong
Modified: 2015-03-05 08:37 EST (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-3.el7
Doc Type: Bug Fix
Doc Text:
console --help output and manpage have been improved.
Story Points: ---
Clone Of:
: 1083786 (view as bug list)
Environment:
Last Closed: 2015-03-05 08:37:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document virt-viewer --full-screen=auto-conf in virt-viewer man page (1.03 KB, patch)
2014-03-12 05:20 EDT, Christophe Fergeau
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0295 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2015-03-05 12:33:00 EST

  None (edit)
Description Geyang Kong 2013-06-04 22:22:16 EDT
Description of problem:
  remote-viewer should add introduction for new added functions into man page and help info.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-1.el7

Reproduce steps:
1.man remote-viewer

Expected results:
1. Remote-viewer now has ability to launch connection from a init file, we should add something to introduce this in man page and help info.
2. Should attach an init file as an example into man page.
3. Should list all options supported by init file in man page or at least provide a link to tell user how to find them and supported values for them.
4. Should add something to introduce spice_proxy and how to set it into man page

Actual results:
1. Nothing
 
Additional info:
Comment 1 luxin 2013-07-30 02:28:37 EDT
I can reproduce the bug

Version:
virt-viewer-0.5.6-1.el7

Steps:
1.# man remote-viewer
2.# remote-viewer --help

Expected results:
1. Remote-viewer now has ability to launch connection from a init file, we should add something to introduce this in man page and help info.
2. Should attach an init file as an example into man page.
3. Should list all options supported by init file in man page or at least provide a link to tell user how to find them and supported values for them.
4. Should add something to introduce spice_proxy and how to set it into man page

Actual results:
1. Nothing about launching connection from a init file and spice_proxy
 
Additional info:
Comment 3 Marc-Andre Lureau 2013-08-08 09:35:43 EDT
I sent a patch to improve man:
https://www.redhat.com/archives/virt-tools-list/2013-August/msg00031.html
Comment 5 hyao@redhat.com 2014-02-07 02:39:15 EST
Reproduced the bug:
# rpm -qa virt-viewer 
virt-viewer-0.5.7-4.el7.x86_64

Steps:
1.# man remote-viewer
2.# remote-viewer --help

Expected results:
1. Remote-viewer now has ability to launch connection from a init file, we should add something to introduce this in man page and help info.
2. Should attach an init file as an example into man page.
3. Should list all options supported by init file in man page or at least provide a link to tell user how to find them and supported values for them.
4. Should add something to introduce spice_proxy and how to set it into man page

Actual results:
1. Nothing about launching connection from a init file and spice_proxy

Recheck the modification on the fixed version: 
# rpm -qa virt-viewer
virt-viewer-0.5.7-6.el7.x86_64

Steps:
1.# man remote-viewer
2.# remote-viewer --help

Actual results:
1. Add the introduction about this function, the init file example, supported options and corresponding values in the man page. 
And there's a typo in Key list as below, should be "silently" not "silentely"
"delete-this-file" (boolean)
           Set to 1 for the client to remove this connection file (if it can't, it will fail silentely)

2. There's no modification about launching remote-viewer by the init file in the help list, is it possible to improve the help? 

Due to the above test result, I assign this bug.
Comment 6 Cui Lei 2014-03-11 22:56:30 EDT
Hi Marcandre,
As comment5, would you please fix the problem(at least fix the typo) or consider to remove this bug from RHEL7.0 errata?

Regards,
Lei
Comment 7 Christophe Fergeau 2014-03-12 05:20:39 EDT
Created attachment 873374 [details]
Document virt-viewer --full-screen=auto-conf in virt-viewer man page

--full-screen=auto-conf is gone upstream so this patch would be RHEL-only. The typo fix is https://www.redhat.com/archives/virt-tools-list/2014-March/msg00052.html
Comment 8 Christophe Fergeau 2014-03-12 05:22:43 EDT
To get this into RHEL7.0, we'd need blocker+ though.
Comment 11 Christophe Fergeau 2014-04-02 04:08:08 EDT
Moved to 7.1. Not sure why I put the '--fullscreen=autoconf' patch in there, probably wrong bug.
Comment 12 Christophe Fergeau 2014-04-02 04:09:45 EDT
Moving back to NEW as "2. There's no modification about launching remote-viewer by the init file in the help list, is it possible to improve the help? " is still missing.
Comment 15 Jonathon Jongsma 2014-07-07 16:50:02 EDT
(In reply to Christophe Fergeau from comment #12)
> Moving back to NEW as "2. There's no modification about launching
> remote-viewer by the init file in the help list, is it possible to improve
> the help? " is still missing.

see commit 657d490e93764274a140794742dae96060e7d944
Comment 17 zhoujunqin 2014-07-22 06:52:28 EDT
I can reproduce with package:virt-viewer-0.5.7-7.el7.x86_64
and try to verify with new build: virt-viewer-0.6.0-1.el7.x86_64

steps:
1. check remote-viewer help info:

# remote-viewer --help
Usage:
  remote-viewer [OPTION...] URI|VV-FILE - Remote viewer client
...
or
# remote-viewer -h
Usage:
  remote-viewer [OPTION...] URI|VV-FILE - Remote viewer client
...
we can see VV-FILE added, but the output format before(virt-viewer-0.5.7-7.el7.x86_64) is:
# remote-viewer --help 
Usage:
  remote-viewer [OPTION...] -- URI - Remote viewer client
                            ^now we can see "--" is missed in new version.

2. check remote-viewer manual page:
# man remote-viewer

NAME
       remote-viewer - a simple remote desktop client

SYNOPSIS
       remote-viewer [OPTIONS] -- [URI]
...

Q1: shall we update SYNOPSIS consistent with "URI|VV-FILE" with help info.

Q2: Issue on Comment 5 still exist.
...
"delete-this-file" (boolean)
           Set to 1 for the client to remove this connection file (if it can't, it will fail silentely)
             ^ wrong typo 

so Marc-Andre Lureau, please help check above issue, does it influence we verify this bug, thanks.
Comment 18 Marc-Andre Lureau 2014-07-22 07:04:14 EDT
(In reply to zhoujunqin from comment #17)
> # remote-viewer --help 
> Usage:
>   remote-viewer [OPTION...] -- URI - Remote viewer client
>                             ^now we can see "--" is missed in new version.

The -- was removed by the following commit. It is not required (it used to be there to show that URI are better placed as last argument)

commit 657d490e93764274a140794742dae96060e7d944
Author: Jonathon Jongsma <jjongsma@redhat.com>
Date:   Tue Jul 1 15:10:48 2014 -0500

> 2. check remote-viewer manual page:
> # man remote-viewer
> 
> NAME
>        remote-viewer - a simple remote desktop client
> 
> SYNOPSIS
>        remote-viewer [OPTIONS] -- [URI]
> ...
> 
> Q1: shall we update SYNOPSIS consistent with "URI|VV-FILE" with help info.

Well, it's also a URI. Man page and --help don't have to be in sync, even if it is nicer.
 
> Q2: Issue on Comment 5 still exist.
> ...
> "delete-this-file" (boolean)
>            Set to 1 for the client to remove this connection file (if it
> can't, it will fail silentely)
>              ^ wrong typo 
> 
> so Marc-Andre Lureau, please help check above issue, does it influence we
> verify this bug, thanks.

right we missed cherry-pick e0e25be56dd9e2d21f55d94ba3e45890b314333d
Comment 19 zhoujunqin 2014-08-06 02:52:18 EDT
Verified with package: 
virt-viewer-0.6.0-3.el7.x86_64

Steps:
1. check remote-viewer manual page:
# man remote-viewer
...
"delete-this-file" (boolean)
           Set to 1 for the client to remove this connection file (if it can't, it will fail silently)
...
we see the "silentely" has been changed to silently.

and according to Comment #18, move this bug from ON_QA to VERIFIED.
Comment 21 errata-xmlrpc 2015-03-05 08:37:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.