Bug 970829 - rhc-admin-migrate will attempt to migrate a gear in the process of being deleted.
rhc-admin-migrate will attempt to migrate a gear in the process of being dele...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 22:48 EDT by Wesley Hearn
Modified: 2015-05-14 20:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:15:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2013-06-04 22:48:43 EDT
Description of problem:
If you start rhc-admin-migrate while a gear is in the process of being deleted it will try to migrate the gear even if mongo reports the gear is not on a server.

Version-Release number of selected component (if applicable):
Latest

How reproducible:
Unknown

Steps to Reproduce:
1. Start deletion of gear
2. Run rhc-admin-migrate
3. Look in /tmp/rhc/migration/ for migrate_

Actual results:
It tried to migrate the gear

Expected results:
It to pass over a gear being deleted

Additional info:
Comment 1 Rajat Chopra 2013-07-09 21:28:10 EDT
Pull request - https://github.com/openshift/origin-server/pull/3028
Use the quarantine flag to not let the 'delete' operation through.
To test this, run 'quarantine-all' script on a system ready for migration.

Try to delete an app, and the request should get denied. Earlier it was possible to do so.
Comment 2 Jianwei Hou 2013-07-11 02:48:48 EDT
Wasn't able to reproduce this bug on devenv_3482, start deleting a gear, then start migrating the gear with oo-admin-upgrade, the migration will stop due to application not found. Mark as verified.
Comment 4 Jianwei Hou 2013-07-11 03:07:02 EDT
Re-tested with quarantine-all script, try to delete an app, the delete request is denied, the client will see "Your application is being upgraded and configuration changes can not be made at this time.  Please try again later."
Therefore, the migration won't be interrupted.

Note You need to log in before you can comment on or make changes to this bug.