Bug 970846 - ucarp - failure of 1 node in a 3 node cluster results in 2 masters
ucarp - failure of 1 node in a 3 node cluster results in 2 masters
Status: CLOSED DUPLICATE of bug 880035
Product: Fedora
Classification: Fedora
Component: ucarp (Show other bugs)
18
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 00:42 EDT by Cam McK
Modified: 2013-06-05 02:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 02:54:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cam McK 2013-06-05 00:42:09 EDT
Description of problem:
* ucarp isn't honouring "--advskew" 
* failure of 1 node in a 3 node cluster results in 2 masters

Version-Release number of selected component (if applicable):
ucarp 1.5.2 - Oct 25 2012
ucarp-1.5.2-7.fc18.x86_64

How reproducible:
Every time

Steps to Reproduce:
Run a 3 node cluster with following parameters:
host 1: ucarp -k 15 -s 192.168.122.191 -v 1 -p badpass -a 192.168.122.200
host 2: ucarp -k 10 -s 192.168.122.13 -v 1 -p badpass -a 192.168.122.200
host 3: ucarp -k 5 -s 192.168.122.38 -v 1 -p badpass -a 192.168.122.200

* Bring up host 2 first, then host 3 and then host 1.
* Kill ucarp on host 2
* host 1 and host 3 both switch to masters 

= When run as a service =
within vip-common.conf set the OPTIONS parameter as:

host1: OPTIONS="--shutdown --advskew 15"
host2: OPTIONS="--shutdown --advskew 5"
host3: OPTIONS="--shutdown --advskew 10"

* start ucarp service on host2, host3, host1
* host2 execute: service ucarp stop

Both host1 and host3 become masters

* Bring host2 back online and host1 and host3 return to backup

Expected results:
Online one master to take over VIP after a node failure
Comment 1 Cam McK 2013-06-05 02:07:48 EDT
Just to expand on this:

The hosts in question are KVM guests. The KVM server is also Fedora 18 (3.9.4-200.fc18.x86_64) It seems that could be a kernel bug as I have the same issues when using keepalived. 

My keepalived symptoms are the same as noted here: http://permalink.gmane.org/gmane.linux.keepalived.devel/3815
Comment 2 Cam McK 2013-06-05 02:54:11 EDT
Given the circumstances I think this bug is a duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=880035

*** This bug has been marked as a duplicate of bug 880035 ***

Note You need to log in before you can comment on or make changes to this bug.