Bug 970855 - Source and Target search and Project-wide search&replace do not work at all
Source and Target search and Project-wide search&replace do not work at all
Status: CLOSED DUPLICATE of bug 953195
Product: Zanata
Classification: Community
Component: Component-UI, Usability, WebSite (Show other bugs)
2.2
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Isaac Rooskov
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 02:10 EDT by Petr Vlcek
Modified: 2015-08-06 01:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:43:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Vlcek 2013-06-05 02:10:17 EDT
Description of problem:

I receive only error message when trying to do any search with Source and target search or Project wide search and replace.


Version-Release number of selected component (if applicable):

Installed from the bundle Zanata 2.2.2 Server (on JBoss AS 5.1.0) with MySQL Community Server database, 5.5.30.

How reproducible:
Install the bundle on given database and try to search anything.

Steps to Reproduce:
1.
2.
3.

Actual results: Error message - Failed to load data from the server. 
Error message logged in browser JS console:

Source and Target search:

(-:-) 2013-06-05 08:01:57,025 [ERROR] GetTransUnits failure net.customware.gwt.dispatch.shared.ActionException: with-clause expressions did not reference from-clause element to which the with-clause was associated [SELECT distinct tf FROM org.zanata.model.HTextFlow tf LEFT JOIN tf.targets tfts WITH index(tfts)=:locale WHERE (tf.obsolete=0 AND tf.document.id=:docId AND ((lower(tf.content0) like :searchString or lower(tf.content1) like :searchString or lower(tf.content2) like :searchString or lower(tf.content3) like :searchString or lower(tf.content4) like :searchString or lower(tf.content5) like :searchString) OR  EXISTS ( FROM org.zanata.model.HTextFlowTarget WHERE (textFlow=tf and locale=:locale and (lower(content0) like :searchString or lower(content1) like :searchString or lower(content2) like :searchString or lower(content3) like :searchString or lower(content4) like :searchString or lower(content5) like :searchString))))) ORDER BY tf.pos]
net.customware.gwt.dispatch.shared.ActionException: with-clause expressions did not reference from-clause element to which the with-clause was associated [SELECT distinct tf FROM org.zanata.model.HTextFlow tf LEFT JOIN tf.targets tfts WITH index(tfts)=:locale WHERE (tf.obsolete=0 AND tf.document.id=:docId AND ((lower(tf.content0) like :searchString or lower(tf.content1) like :searchString or lower(tf.content2) like :searchString or lower(tf.content3) like :searchString or lower(tf.content4) like :searchString or lower(tf.content5) like :searchString) OR  EXISTS ( FROM org.zanata.model.HTextFlowTarget WHERE (textFlow=tf and locale=:locale and (lower(content0) like :searchString or lower(content1) like :searchString or lower(content2) like :searchString or lower(content3) like :searchString or lower(content4) like :searchString or lower(content5) like :searchString))))) ORDER BY tf.pos]

Project-wide search&replace:

2013-06-05 08:08:37,125 [ERROR] [SearchResultsPresenter] failed project-wide search request: with-clause expressions did not reference from-clause element to which the with-clause was associated [SELECT distinct tf FROM org.zanata.model.HTextFlow tf LEFT JOIN tf.targets tfts WITH index(tfts)=:locale WHERE (tf.obsolete=0 AND tf.document.id in (:documentIds) AND ((lower(tf.content0) like :searchString or lower(tf.content1) like :searchString or lower(tf.content2) like :searchString or lower(tf.content3) like :searchString or lower(tf.content4) like :searchString or lower(tf.content5) like :searchString) OR  EXISTS ( FROM org.zanata.model.HTextFlowTarget WHERE (textFlow=tf and locale=:locale and (lower(content0) like :searchString or lower(content1) like :searchString or lower(content2) like :searchString or lower(content3) like :searchString or lower(content4) like :searchString or lower(content5) like :searchString))))) ORDER BY tf.pos]


Expected results: Any search results
Comment 1 Sean Flanigan 2013-06-06 21:43:26 EDT

*** This bug has been marked as a duplicate of bug 953195 ***

Note You need to log in before you can comment on or make changes to this bug.