Bug 970863 - segment in conversion is strange
Summary: segment in conversion is strange
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libkkc (Show other bugs)
(Show other bugs)
Version: 19
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-05 06:27 UTC by Akira TAGOH
Modified: 2013-10-11 23:58 UTC (History)
3 users (show)

Fixed In Version: libkkc-0.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 23:02:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Akira TAGOH 2013-06-05 06:27:09 UTC
Description of problem:
When I type "nihongonotesutodesu." and space to convert, segments looks like this:
[日本][語][の][テスト][で][す][。]

In most Japanese IM, it should looks like the following and what I'm expecting to kkc too:
[日本語の][テストです][。]

Version-Release number of selected component (if applicable):
libkkc-0.2.3-1.fc19.x86_64
ibus-kkc-1.5.13-1.fc19.x86_64

Comment 1 Akira TAGOH 2013-06-05 06:29:03 UTC
or [日本][語の][テストです][。]

Comment 2 Daiki Ueno 2013-09-11 04:21:30 UTC
https://gitorious.org/libkkc/libkkc/commit/a4873634d641709b91c288d018e1c13cca5a856b

Ad-hoc, but seems to work better.

Comment 3 Fedora Update System 2013-09-11 13:04:23 UTC
libkkc-0.3.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libkkc-0.3.0-1.fc20

Comment 4 Fedora Update System 2013-09-11 13:04:35 UTC
libkkc-0.3.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libkkc-0.3.0-1.fc19

Comment 5 Fedora Update System 2013-09-11 16:58:21 UTC
Package libkkc-0.3.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libkkc-0.3.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16416/libkkc-0.3.0-1.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-09-15 23:07:16 UTC
libkkc-0.3.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libkkc-0.3.1-1.fc20

Comment 7 Fedora Update System 2013-09-15 23:07:26 UTC
libkkc-0.3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libkkc-0.3.1-1.fc19

Comment 8 Fedora Update System 2013-09-24 23:02:20 UTC
libkkc-0.3.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-10-11 23:58:45 UTC
libkkc-0.3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.