Bug 970864 - Testsuite failure: Extra PLT reference
Summary: Testsuite failure: Extra PLT reference
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-05 06:39 UTC by Siddhesh Poyarekar
Modified: 2016-11-24 12:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 09:23:23 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Siddhesh Poyarekar 2013-06-05 06:39:29 UTC
Description of problem:
The current rawhide build (in progress, 2.17.90-1.fc20) has an extra PLT reference in libc.so:

=====/builddir/build/BUILD/glibc-2.17-757-g96df079/build-x86_64-redhat-linux/elf/check-localplt.out=====
Extra PLT reference: libc.so: memset

Version-Release number of selected component (if applicable):
glibc-2.17.90-1.fc20

How Reproducible:
Always

Steps to Reproduce:
See build log.

Comment 1 Siddhesh Poyarekar 2013-06-11 03:28:47 UTC
binutils is getting the symbol name wrong somehow, but the breakage is real.  The extra PLT is for __GI___gettimeofday, not memset.  the F17 version of binutils also got the name wrong as malloc, but since malloc is excluded from the extra PLT check, this failure went unnoticed.

There's no point in avoiding a PLT for __gettimeofday and for similar reasons, the hidden definition is also useless.  Any overhead added to avoid the PLT would be more expensive that the additional PLT.  I'm considering removing those bits and adding a direct call to __gettimeofday.


Note You need to log in before you can comment on or make changes to this bug.