Bug 970869 - missed Requires perl(CPAN::Perl::Releases)
missed Requires perl(CPAN::Perl::Releases)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perlbrew (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 02:49 EDT by Robin Lee
Modified: 2013-06-29 14:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: perlbrew-0.64-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 01:52:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Lee 2013-06-05 02:49:33 EDT
Description of problem:
Missed Requires perl(CPAN::Perl::Releases). Some commands of perlbrew use this module. And the module is listed in Makefile.PL.

Version-Release number of selected component (if applicable):
perlbrew-0.62-1.fc18.noarch

How reproducible:
# yum install perlbrew
...
$ perlbrew install perl-stable -j 2 -D useithreads
Can't locate CPAN/Perl/Releases.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/vendor_perl/App/perlbrew.pm line 542.
Comment 1 Fedora Update System 2013-06-07 09:24:38 EDT
perlbrew-0.64-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perlbrew-0.64-1.fc19
Comment 2 Fedora Update System 2013-06-07 09:24:57 EDT
perlbrew-0.64-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perlbrew-0.64-1.fc18
Comment 3 Fedora Update System 2013-06-07 19:50:27 EDT
Package perlbrew-0.64-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perlbrew-0.64-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10308/perlbrew-0.64-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-23 01:52:44 EDT
perlbrew-0.64-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-06-29 14:24:36 EDT
perlbrew-0.64-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.