Bug 97087 - docbook2man doesn't quote dots at the beginning of the line
docbook2man doesn't quote dots at the beginning of the line
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 00:51 EDT by Gordon Messmer
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 0.6.13-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 04:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
always quotes dots at the beginning of the line (587 bytes, patch)
2003-06-10 00:52 EDT, Gordon Messmer
no flags Details | Diff

  None (edit)
Description Gordon Messmer 2003-06-10 00:51:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When converted to nroff format, a dot at the beginning of the line starts a
macro.  If a docbook file has a dot at the beginning of one of its lines of
text, man will either not display the following word, or not display then entire
line of text (depending on the version of man).

The fix is pretty simple, '.' characters at the beginning of a line of text must
always be quoted as '&.' (ampersand-dot, in case it gets lost in the HTML).  The
upstream author has been notified, and corrected the problem in the current
series of docbook-utils.  I'll attach a patch for the version that you're
distributing.  It works for me.

Version-Release number of selected component (if applicable):
docbook-utils-0.6.12-5
Comment 1 Gordon Messmer 2003-06-10 00:52:44 EDT
Created attachment 92292 [details]
always quotes dots at the beginning of the line
Comment 2 Tim Waugh 2003-06-10 04:36:55 EDT
Thanks.  Fixed package will appear in rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.