Bug 9709 - kernel tries to exec zero-length file
Summary: kernel tries to exec zero-length file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-23 12:38 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 23:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-02-23 12:38:51 UTC
Create a zero-length file.  Make it executable.

Modify /etc/syslog.conf to log *.debug into a file.  Create the empty log
file and send a HUP to syslogd.

Try to execute the zero-length file.  In your debug syslog log file, you'll
see, "modprobe: modprobe: Can't locate module binfmt-0000".

The kernel should not be trying to load a module to execute an empty file.

Comment 1 Alan Cox 2000-09-14 23:57:01 UTC
Its an interesting question since there is no kernel problem with leavign this
allowed. I suspect someone should by default 'alias binfmt-0000 off'


Comment 2 Bill Nottingham 2001-07-06 22:33:54 UTC
will be done in 2.4.6-1.


Note You need to log in before you can comment on or make changes to this bug.