Bug 970928 - Sometimes migration message is not logged.
Summary: Sometimes migration message is not logged.
Status: CLOSED DUPLICATE of bug 965525
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
(Show other bugs)
Version: 3.1.0
Hardware: Unspecified Linux
unspecified
unspecified
Target Milestone: ---
: 3.3.0
Assignee: Shahar Havivi
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-05 08:56 UTC by Yoshinori Takahashi
Modified: 2018-12-01 14:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 06:32:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18164 None None None Never

Comment 1 Michal Skrivanek 2013-06-14 11:16:45 UTC
analogous to bug 697277. Maybe instead of rewrite of the logic we just ad a notion of "source" and "destination" VM so it's clear where does it happen and if it is relevant? Not a solution but it would at least help...

Comment 2 Michal Skrivanek 2013-07-29 12:48:24 UTC
let's go with comment #1 then

Comment 3 Shahar Havivi 2013-08-15 09:00:10 UTC
I cannot reproduce this issue (I never got the "Exit Message" audit log).
By examining the code it does looks like this scenario may happened, the list that used for storing running VMs is not synchronized.

Comment 4 Shahar Havivi 2013-08-15 09:49:56 UTC
After talking with Omer, 
This may not be the problem since the VdsUpdateRuntimeInfo is running in a single thread...
Aborting the patch.

Yoshinori can you please reproduce the message and attach the Engine and VDSM logs.

Comment 5 Michal Skrivanek 2013-09-17 06:32:51 UTC
it seems to be the same issue as in bug 965525

*** This bug has been marked as a duplicate of bug 965525 ***


Note You need to log in before you can comment on or make changes to this bug.