Bug 970941 - rhel5 guest can't start desktop environment with vga video device
Summary: rhel5 guest can't start desktop environment with vga video device
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-vesa (Show other bugs)
(Show other bugs)
Version: 5.9
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: rc
: 5.9
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-05 09:46 UTC by CongDong
Modified: 2014-06-17 11:00 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 12:49:14 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (13.59 KB, text/plain)
2013-06-06 01:58 UTC, CongDong
no flags Details

Description CongDong 2013-06-05 09:46:26 UTC
Description of problem:
After I install a rhel5 guest on rhel7, I change the guest's video device to vga, then the guest's desktop environment can't start, I tried on rhel6, and it works well, rhel6 guest on rhel7 is ok too.

Version-Release number of selected component (if applicable):
qemu-kvm-1.5.0-2.el7.x86_64
kernel-3.9.0-0.55.el7.x86_64
libvirt-1.0.5-2.el7.x86_64
virt-manager-0.10.0-0.4.gitb68faac8.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Install a rhel5 guest with GNOME desktop environment, make sure it can work well with "cirrus" type video device.
2.Shutdown rhel5 guest, and change the video device to "vga".
3.Start the rhel5 guest
4.Edit file "/etc/X11/xorg.conf", change the "Driver" under "Section 'Device'" to "vesa" like this:
...
Section "Device":
	Identifier "Videocard0"
	Driver	   "vesa"
...

5.Run command "startx" to start the guest's desktop environment.

Actual results:
step3, The guest will start without desktop environment.
step5, Failed to start the X server.

Expected results:
After step5, guest can start it's desktop environment and work well.

Additional info:

Comment 2 Daniel Berrange 2013-06-05 13:46:17 UTC
Please provide the /var/log/Xorg.0.log file showing the failed startup attempt.

Comment 3 CongDong 2013-06-06 01:58:13 UTC
Created attachment 757458 [details]
Xorg.0.log

Comment 4 Daniel Berrange 2013-06-06 07:43:16 UTC
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/lib64/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(II) VESA(0): initializing int10
(II) VESA(0): Primary V_BIOS segment is: 0xc000

Backtrace:
0: X(xf86SigHandler+0x71) [0x479b01]
1: /lib64/libc.so.6 [0x2adf524ef330]
2: /usr/lib64/xorg/modules/libint10.so [0x2adf54ea96d3]
3: /usr/lib64/xorg/modules/libint10.so(Mem_rb+0x18) [0x2adf54ea7b28]
4: /usr/lib64/xorg/modules/libint10.so(fetch_data_byte+0x2a) [0x2adf54eaa80a]
5: /usr/lib64/xorg/modules/libint10.so [0x2adf54eac4b2]
6: /usr/lib64/xorg/modules/libint10.so(X86EMU_exec+0x9d) [0x2adf54eba1cd]
7: /usr/lib64/xorg/modules/libint10.so(xf86ExecX86int10+0x55) [0x2adf54ea9675]
8: /usr/lib64/xorg/modules/libvbe.so(VBEExtendedInit+0x92) [0x2adf54c9b5c2]
9: /usr/lib64/xorg/modules/drivers/vesa_drv.so [0x2adf54686cd6]
10: X(InitOutput+0x9cd) [0x4642fd]
11: X(main+0x26f) [0x4335ef]
12: /lib64/libc.so.6(__libc_start_main+0xf4) [0x2adf524dc9c4]
13: X(FontFileCompleteXLFD+0x241) [0x432aa9]

Fatal server error:
Caught signal 11.  Server aborting


So either this is a bug in the rhel5 vesa driver, or bad emulation in QEMU is violating some requirement in the driver causing the crash. Re-assigning to rhel5 xorg for further diagnosis

Comment 5 RHEL Product and Program Management 2014-03-07 13:54:49 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 6 Cui Lei 2014-03-10 02:25:24 UTC
Discussed with reporter, only vga mode would meet this issue, other types of mode works well. So it is not a block issue, agree with closing it as wontfix.

Comment 7 RHEL Product and Program Management 2014-06-03 12:49:14 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.